cancel
Showing results for 
Search instead for 
Did you mean: 

Could not export configuration for index: name=master_backoffice_backoffice_product_flip

djboyd4715
Participant

Hello

I have posted several questions :

on this topic as well as opening a ticket with SAP, but so far an answer escapes me.

Recap

Upgrade CCV2:6.4 to CCV2:2105

We did not implement the product cockpit before we went live. Now, we have a need to make this active.

I am using a local deployment in order to work out the process needed.

I have attached our localextensions.xml for review to determine if there are any additional extensions that need to be added.

The build process I am using on local is:

ant customize

ant addonuninstall -Daddonnames="acceleratorwebservicesaddon,assistedservicepromotionaddon,assistedservicestorefront,driveacceleratorb2baddon,drivecommercecompanyaddon,driveinvoiceaddon,driveselfserviceaddon,sapcoreaddon,captchaaddon,pcmbackofficesamplesaddon,adaptivesearchsamplesaddon" -DaddonStorefront.yacceleratorstorefront="drivestorefront"

ant clean all

ant update -DconfigFile=update.json ( update.txt )

Once server is started, I run a few impex:

  • /hybris/bin/modules/adaptive-search/adaptivesearch/resources/impex/essentialdata-adaptivesearch.impex
  • /hybris/bin/modules/search-and-navigation/solrfacetsearch/resources/impex/essentialdataSolr.impex
  • /hybris/bin/modules/search-and-navigation/backofficesolrsearch/resources/impex/productSolr.impex
  • /hybris/bin/modules/search-services/backofficesearchservices/resources/impex/productSearchservices.impex
  • /hybris/bin/modules/backoffice-addons/pcmbackofficesamplesaddon/resources/pcmbackofficesamplesaddon/import/common/common-addon-extra.impex
  • /hybris/bin/modules/backoffice-addons/pcmbackofficesamplesaddon/resources/pcmbackofficesamplesaddon/import/common/user-groups.impex

I can access the product cockpit but the data quality widget is empty. I have gone through the process of reseting the back office but that does not change anything

I then run all of my indexes - US Product, CA Product. Then I run Solr Config for Backoffice, and I get the following errors

ERROR [BackofficeLO-13] (00000JAG) [SolrStandaloneSearchProvider] Server refused connection at: https://localhost:8983/solr
org.apache.solr.client.solrj.SolrServerException: Server refused connection at: https://localhost:8983/solr


Caused by: org.apache.http.conn.HttpHostConnectException: Connect to localhost:8983 [localhost/127.0.0.1, localhost/0:0:0:0:0:0:0:1] failed: Connection refused (Connection refused)
ERROR [BackofficeLO-13] (00000JAG) [BackofficeIndexerStrategy] Executing indexer worker as an admin user failed:
de.hybris.platform.solrfacetsearch.indexer.exceptions.IndexerException: de.hybris.platform.solrfacetsearch.solr.exceptions.SolrServiceException: Could not export configuration for index: name=master_backoffice_backoffice_product_flip

Caused by: de.hybris.platform.solrfacetsearch.solr.exceptions.SolrServiceException: Could not export configuration for index: name=master_backoffice_backoffice_product_flip

Caused by: de.hybris.platform.solrfacetsearch.solr.exceptions.SolrServiceException: Could not reload configuration for index: name=master_backoffice_backoffice_product_flip, nodes=[https://localhost:8983/solr]
I do not understand why this is having an issue connecting to solr when the other indexes do not.

I have set up all indexes to use Local Standalone

Any direction or help in this matter

Accepted Solutions (0)

Answers (0)