cancel
Showing results for 
Search instead for 
Did you mean: 

Unable to run hybrisserver.bat in start mode, FATAL | wrapper

Former Member
0 Kudos

[Hybris 6.6.0] ,[ Windows 64 bit ] Hello, I am having issues in executing the command "hybrisserver.bat start", I am getting the following message : { FATAL | wrapper | Failed to load configuration: C:\Hybris\hybris\bin\platform\tomcat\bin\" }

However, when i run commands such as "hybrisserver.bat" or "hybrisserver.bat debug" the server starts up properly. I think I have made some unwanted changes to the specific code piece for start mode as the message path { platform\tomcat\bin\" } doesn't seem to be correct to me. I am not able to locate the reason/file for the error though. I've tried deleting the base config folder at C:\Hybris and running ant clean all but still the error persists.

Accepted Solutions (1)

Accepted Solutions (1)

Former Member
0 Kudos

Hi Vivek

as you are still in the early steps of 123, and have deleted/moved folders, I would suggest starting from a clean slate:

  • " Delete any existing hybris services on your Windows platform: (open regedit, navigate to HKEY_LOCAL_MACHINE -> SYSTEM -> CurrentControlSet -> Services, and if you see a hybrisServer entry there, select it and delete it). "

  • Restart Windows, to ensure that all Hybris Services are stopped. "

  • Unpack a brand new commerce suite, and start 123 again, keeping in mind the points in our earlier emails:

  • "Set up a Git repository in the folder /hybris" means the existing folder "/hybris". It should not require the creation of a new folder (hybris2). "

  • Also, be sure to personalize the 123 trail by entering C:/Hbyris in the field "Path to your Hybris123 Directory:" as illustrated in the attachment. (This should happen automatically, but if not please do so manually)

Former Member

Hi Ken,

I had the same issue and I did exactly as you mentioned above. After reinstalling hybris and going through the trail, everything was good till my machine rebooted and the same error is back again. Don't know if this is a bug in HYBRISCOMM6700P_12-80003492.

I'm sure there would be more people out there getting the same error and there needs to be a simple fix, which I don't know yet.

Regards,

Answers (2)

Answers (2)

jose1914luis
Discoverer
0 Kudos

I solved this using this commands:

set _YWRAPPER_CONF=%HYBRIS_HOME_DIR%\hybris\bin\platform\tomcat\conf\wrapper.conf 
cd %HYBRIS_HOME_DIR%\hybris\bin\platform\tomcat\bin & InstallTomCatService.bat  
cd %HYBRIS_HOME_DIR%\hybris\bin\platform & hybrisserver.bat start
VinayKumarS
Active Contributor
0 Kudos
  1. check your javac -version and java -version from command prompt.

  2. check your RAM. If both are fine then you should be OK.

Also check your 32bit or 62bit OS. Install java accordingly.

Former Member

Java and javac versions are fine : both 1.8

OS is 64 bit and available RAM is also enough. As I've mentioned in the question, it's not a JVM or shortage of memory problem. The hybris server starts when i use "debug" mode or just normal "hybrisserver.bat" but it gives a config loading error with specifically "start" mode. I think i have mistakenly changed the conf file path somewhere for the start mode specific code but I don't know which might be the file. ant clean all doesn't help either. Also, the "hybrisserver.bat" command was working fine till yesterday, so it's not a system issue