cancel
Showing results for 
Search instead for 
Did you mean: 

Problem in setting a language to a default in ICSS application?

Former Member
0 Kudos
56

Hi Gurus,

I am having a problem in logging into application with the language selected. Even if i select the language as english, it is logging in with french content. What ever language i select, it is coming with french language. Please help me in this.

Is there any setting made somewhere that what ever language we select, it will get defaulted to one language??

Thanks a lot in advance.

Regards,

Lakshman.

Accepted Solutions (1)

Accepted Solutions (1)

Former Member
0 Kudos

Hi Lakshman,

Go to XCM setting of your ICSS application go to

Comonents --> Customer --> ui.

Create new ui element. Over here you can select default language for your ICSS web application. Save it by giving some name like "lan1"

Now go to Application Configuration --> Customer --> <your Configuration>

Here click on "Display" Button of "Advance Setting" go to "ui Data" selection box and select "lan1" from drop down box save it and restart your application.

I hope this will open with your default language which you have set in "uidata " component "lan1"

Regards.

eCommerce Developer

Former Member
0 Kudos

Hi,

My problem is different. I dont want to set any default language. Sorry if i mislead with the post. My problem is , in the login page we have multiple languages and what ever language we select, it is logging in with french language. The language parameter setting is FR. PLease help me.

THnaks a lot!

Regards,

Lakshman.

Former Member
0 Kudos

Have you checked in your login page jsp.

Is Language parameter is hard coded in your Login page.

Also try to check below section in "init-config.xml" files and check what language you have.


*<initialization className="com.sap.isa.user.util.UserInitHandler">*

*"UserInitHandler.java" read language parameter values from "init-config.xml" file and set the languages.

I hope this will help you to resolve your problem.

eCommerce Developer

Former Member
0 Kudos

Hi,

I am getting all the languages that i want from init-config.xml . All the languages which i have in init-config.xml are coming in the dropdown also. But from the dropdown in login page, what ever language i select, it is logging in with french language.

Thank you,

Lakshman.

Former Member
0 Kudos

try to add language attribute at the end of your URL and then login.

/init.do?language=EN

Let us know is it working?

eCommerce Developer.

Answers (1)

Answers (1)

Former Member
0 Kudos

solved