cancel
Showing results for 
Search instead for 
Did you mean: 

Pricing userexit in JAVA - unsupported major.minor version 50.0

raymond_amalraj
Explorer
0 Kudos
104

Hi ,

I am relatively new to userexits in Java for pricing related requirements in CRM sales order. Currently the requirement is such that in sales order, a simple pricing requirement needs to be setup that checks order net value is greater than 150. To do this, i read through the userexit manual and developed the Java userexit for the requirement. I have done the config related to that. I can see my requirement is already there in CRM system as 902. But when a sales order is created, it gives a error messages as below :

my/sap/pricing/userexits/req/ZDiscountRequirement (Unsupported major.minor version 50.0)

I am not sure if this error has been reported by others in this forum. I searched for it . Din't get it. so posting a new thread.

Appreciate your help !

Thanks ,

Raymond.

Accepted Solutions (1)

Accepted Solutions (1)

raymond_amalraj
Explorer
0 Kudos

Hi,

Is there anybody who has encountered this error before? Appreciate your help !

0 Kudos

Assuming you are using Eclipse, which comes with a project specific java settings, you can set different java compiler levels for different projects which often overrides the java compiler setting on the OS. If you change this to match the JRE level the problem should be eliminated.

raymond_amalraj
Explorer
0 Kudos

Thank you Krish! It did work for me this way. I was using 1.6 compiler instead 1.4 . Hence the problem. Points awarded!

Former Member
0 Kudos

Hi,

I too am facing the same issue with service order. How do I rectify this error? How do I check the JRE level?

Regards,

Abdullah

Answers (1)

Answers (1)

Former Member
0 Kudos

Hi,

I am also facing the Same error.

Error:unsupported major.minor version 51.0. when i create the CRM Sales Order and pricing procedure not triggered in Sales Order.

Condition Value Formula 951 Developed/Compiled the UserExit with Eclipse IDE and Both  JRE/JDK 1.4.19

Local  PC JAVA Version is 1.7.X

Should  the LOCAL PC  and SAP CRM Server JAVA Version has to be same/higher?

Please explain me more on this to solve the Error.

  

Thanks

 

MH