cancel
Showing results for 
Search instead for 
Did you mean: 

Getting Exception while "update running system" Exception as org.apache.ddlutils.DatabaseOperationException: com.microsoft.sqlserver.jdbc.SQLServerException: Incorrect syntax near '7573426'.

0 Kudos
260

HI All,

Can you please help me to solve the below exception. I am getting the exception while i am update the system with " update running sytem" here is exception

Updating system... INFO | jvm 1 | srvmain | 2017/06/08 21:18:55.882 | ### Starting type system update INFO | jvm 1 | srvmain | 2017/06/08 21:18:55.882 | >>> Updating schema (and type system)... INFO | jvm 1 | srvmain | 2017/06/08 21:18:55.897 | Fetching type system related entities INFO | jvm 1 | srvmain | 2017/06/08 21:18:55.897 | 453 deployments have been fetched in 49,41 ms INFO | jvm 1 | srvmain | 2017/06/08 21:18:56.007 | 1283 composedtypes have been fetched in 211,4 ms INFO | jvm 1 | srvmain | 2017/06/08 21:18:58.300 | 27878 attributess have been fetched in 2,215 s INFO | jvm 1 | srvmain | 2017/06/08 21:18:58.300 | 22 atomictypes have been fetched in 7,522 ms INFO | jvm 1 | srvmain | 2017/06/08 21:18:58.300 | 575 collectiontypes have been fetched in 22,77 ms INFO | jvm 1 | srvmain | 2017/06/08 21:18:58.315 | 40 maptypes have been fetched in 6,987 ms INFO | jvm 1 | srvmain | 2017/06/08 21:18:58.315 | 757 enumerationvalues have been fetched in 28,35 ms INFO | jvm 1 | srvmain | 2017/06/08 21:18:58.315 | 244 numberseries have been fetched in 10,98 ms INFO | jvm 1 | srvmain | 2017/06/08 21:19:15.273 | 740906 props have been fetched in 16,94 s INFO | jvm 1 | srvmain | 2017/06/08 21:19:16.692 | Initialization of DbTypeSystem has taken 20,87 s INFO | jvm 1 | srvmain | 2017/06/08 21:19:16.692 | Reading type system Information. INFO | jvm 1 | srvmain | 2017/06/08 21:19:18.003 | Read type system Information. Time taken 1,392 s INFO | jvm 1 | srvmain | 2017/06/08 21:19:18.003 | Preparing Db model. INFO | jvm 1 | srvmain | 2017/06/08 21:19:29.770 | Prepared Database Model with (920) tables. INFO | jvm 1 | srvmain | 2017/06/08 21:19:29.770 | Prepared Db model. Time taken 11,74 s INFO | jvm 1 | srvmain | 2017/06/08 21:19:30.331 | Preparing target and source models INFO | jvm 1 | srvmain | 2017/06/08 21:19:30.659 | Failed to initialize INFO | jvm 1 | srvmain | 2017/06/08 21:19:30.659 | org.apache.ddlutils.DatabaseOperationException: com.microsoft.sqlserver.jdbc.SQLServerException: Incorrect syntax near '7573426'. INFO | jvm 1 | srvmain | 2017/06/08 21:19:30.659 | at org.apache.ddlutils.platform.PlatformImplBase.readModelFromDatabase(PlatformImplBase.java:1931) INFO | jvm 1 | srvmain | 2017/06/08 21:19:30.659 | at org.apache.ddlutils.platform.PlatformImplBase.readModelFromDatabase(PlatformImplBase.java:1904) INFO | jvm 1 | srvmain | 2017/06/08 21:19:30.659 | at de.hybris.bootstrap.ddl.HybrisMSSqlPlatform.readModelFromDatabase(HybrisMSSqlPlatform.java:46) INFO | jvm 1 | srvmain | 2017/06/08 21:19:30.659 | at de.hybris.bootstrap.ddl.HybrisSchemaGenerator.update(HybrisSchemaGenerator.java:218) INFO | jvm 1 | srvmain | 2017/06/08 21:19:30.674 | at de.hybris.platform.core.Initialization.initializeSchemaAndTypeSystemFullyNewStyle(Initialization.java:1223) INFO | jvm 1 | srvmain | 2017/06/08 21:19:30.690 | at de.hybris.platform.core.Initialization.initialize(Initialization.java:1093) INFO | jvm 1 | srvmain | 2017/06/08 21:19:30.706 | at de.hybris.platform.core.Initialization.createEmptySystemOrUpdate(Initialization.java:788) INFO | jvm 1 | srvmain | 2017/06/08 21:19:30.706 | at de.hybris.platform.core.Initialization.access$4(Initialization.java:767) INFO | jvm 1 | srvmain | 2017/06/08 21:19:30.721 | at de.hybris.platform.core.Initialization$4.call(Initialization.java:587) INFO | jvm 1 | srvmain | 2017/06/08 21:19:30.721 | at de.hybris.platform.core.Initialization$4.call(Initialization.java:1) INFO | jvm 1 | srvmain | 2017/06/08 21:19:30.737 | at de.hybris.platform.core.Initialization$SessionRecoveryAfterRegistryStartupAwareExecutor.execute(Initialization.java:709)

Thanks Vijay

Accepted Solutions (0)

Answers (1)

Answers (1)

Former Member
0 Kudos

Hello Vijay, I am currently having the same problem while trying to execute ant updatesystem -DtypeSystemOnly=true command. Were you able to fix this error?

We are using Hybris 6.6 with Hana DB

geffchang
Active Contributor
0 Kudos

What is the exact version you are using? x.x.x.x?