cancel
Showing results for 
Search instead for 
Did you mean: 

Enhancing the Service Request Search with Custom Z.. field

0 Kudos

Hi All,

I am enhacing the Component SRQM_INCIDENT_S with custom field ZFIELD. Below are the steps which i took:

1.

 

BSP_WD_CMPWB I enter the name of the component "SRQM_INCIDENT_S"

clicked on Button to enhance component

assign the enhancement set "Z..."

Give the name of the Application " ZSRQMINCIDENT_S'

Confirm that i want to create  the BSP application  that doesnt exist

Left the name of the repositiry as "Repository.xml"

Assigned Workbench Request

Then enhanced the view  " SRQM_INCIDENT_S/IncidentSR"

2. After this i selected the Search view of this Component

   - navgate to the context Node  of this view

   - opened context node and right clicked on Attributes node

   - select  Otion CREATE

3. Wizard started did select the  ADD TO MODEL  ATTRIBUTE

   - For BOL Entity selected ----> BTQSRVREQ And used realations to navigate through the BOL structure and got the ZField as below

BTSRQMObject/BTOrderHeader/BTHeaderPartnerSet/BTPartnerAll/BTBusinessPartner/ZZFLD00001V

After this my field is succesfully added on the Attributes of this SEARCH Context Node as:

Z_WARD ( Dynamic - See A-Getter)

All the other GET Method are Green except GET_V_Z_WARD & GET_P_Z_WARD.

I did a log Out and Logged in back again in the system.

I expected the Zfield to be availabe in the Configuration Tab on the Available Serch Criteria but its not there.

Could there be anywwhere where i am getting it wrong?

Thank you for your help in advance.

Regards,

Bryce

Accepted Solutions (0)

Answers (2)

Answers (2)

Former Member
0 Kudos

Hi Bruce,

Did you manage to workaround this issue?

We are facing exactly the same.

Thanks for your inputs!

Best regards,

Geert

Former Member
0 Kudos

if you want to enable additional search criteria for service request:

1) Add your field in se11 to structure crmst_query_r_srv_req_btil.

2) Enhance enhancement spot es_crm_rf_Q10_search in se18.

0 Kudos

Hi Bryce,

You have to assign it in the design layer and make it visible.

Thanks & Best Regards,

Leon