cancel
Showing results for 
Search instead for 
Did you mean: 

CX_BSP_ELEMENT_EXCEPTION after upgrading CRM 7.0 to EhP3

Former Member
0 Kudos
104

Hi,

I get the following error after upgrading to CRM 7.0 EhP3, when logging into WebUI. I seem to remember fixing this before, but I can't for the life of me remember how I did it. Does anyone have a pointer of where to start looking?

Thank you!

John

Business Server Page (BSP) error


What happened?

Calling the BSP page was terminated due to an error.

SAP Note
  • The following error text was processed in the system:
    <thtmlb:cellerator>: (hasExpander) Incorrect Boolean Value
Exception ClassCX_BSP_ELEMENT_EXCEPTION
Error Name
ProgramCL_BSP_ELEMENT_RT_ATTR_VALID==CP
IncludeCL_BSP_ELEMENT_RT_ATTR_VALID==CM002
ABAP ClassCL_BSP_ELEMENT_RT_ATTR_VALID
MethodERROR
Line18
Long text-

Error type: Exception

Your SAP Business Server Pages Team

Accepted Solutions (1)

Accepted Solutions (1)

nicolas_busson
Active Contributor
0 Kudos

Hi John,

Did you check this note already?

http://service.sap.com/sap/support/notes/1882839

Cheers

Nick.

Former Member
0 Kudos

Thanks for the reply!

Yep - this is how you reproduce the error in that note:

Reproducing the Issue

  1. Log into the WebUI with the specific Business role
  2. Select the Configure Page button
  3. Change the configuration and save
  4. Short dump occurs

My dump happens when you first login to the UI. I sense that the problems are related and the problem is in the CRM Workbench, I just can't figure out where to look in TX BSP_WD_CMPWB.

nicolas_busson
Active Contributor
0 Kudos

What business role are you using? Because if it's ic_agent for example i would check the configuration of the identification view for example. And if you have no clue where to start looking, try to set a breakpoint in the method mentioned in the note: you should be able to spot the faulty view pretty fast i guess.

nicolas_busson
Active Contributor
0 Kudos

And did you try to start the "webui consistency check" report?

Former Member
0 Kudos

So this is a Business Role based issue. I added Parameter CRM_UI_PROFILE=SALESPRO to my user in SU01 like in this blog and it is OK.

Guess this is a suitable workaround for now as I only need this as for a test project with

Thanks!

Former Member
0 Kudos

There is a WebUI consistency check? Can't find it on Google!

Former Member
0 Kudos

LOL thanks how did I not find it. Amusingly the link doesn't tell you how to run it. Figured it out...

- SPRO

- Customer Relationship Management

- UI Framework

- UI Framework Definition

- Perform WebClient UI Framework Checks

You can't check a role directly though, just a customization. Though this will definitely help me fix the next two problems, which are broken customized screens. Suspect it is new standard fields in WebUI which are expected by WebUI and don't exist in my custom copies from EhP0

nicolas_busson
Active Contributor
0 Kudos

This is the note i was looking for, finally!

http://service.sap.com/sap/support/notes/1570869

Good luck with your "test" project 😉

Nick.

Former Member
0 Kudos

Thanks

Here's a hint!

Answers (0)