cancel
Showing results for 
Search instead for 
Did you mean: 

Custom attribute added to result view context node not visible in configuration

Former Member
0 Kudos
1,082

I have added a model attribute to the context node of a result view. But, that custom attribute is not visible in configuration UI to move to display fields. I have tried with adding the field to BOL structure of that context node. Though it is visible in the attributes list in component work bench, I could not see in configuration UI. How can I over come this problem?  Regards DNR Varma

Accepted Solutions (1)

Accepted Solutions (1)

former_member193352
Active Contributor
0 Kudos

Hi

I'd like to support what Kavindra has suggested in his post.

If you still don't want to do that, can you please check if the Context node attribute is assigned to the design layer. If not, please create a default design layer assignment by right clicking on the attribute and the attribute should be visible in the UI config after that.

Thanks

Vishal    

Former Member
0 Kudos

Hi



I have achieved that through the following procedure

1. Choose 'Assignment to design layer' and click on button 'Assignment' (insert assignement).

2. Scroll down to the bottom of the pop up and select the option 'No Design Layer'.

3. Click on save and continue.

Now, the fields are availabe in configuration.

Answers (4)

Answers (4)

Former Member
0 Kudos

By default, your custom attribute will not appear in the 'Available Fields' list. It is always necessary to add it first to the Design layer, which is where the CRM web UI reads its data from.

Solution 1: Go to SPRO > CRM > UI Framework > UI Framework Definition > Design Layer > Deactivate Hiding of Fields

The problem could indeed be solved by 'Deactivating the Hiding of Fields', but this means that all custom fields will always be available throughout the system in the future. It is therefore recommended to only expose the fields that are needed, using the simple technique in solution 2.

Solution 2: Go to SPRO > CRM > UI Framework > UI Framework Definition > Design Layer > Define Design Objects

- Select the desired object type (e.g. BT111H_OPPT, BT126_CALL, etc.).

- From the 'Design Object' list, select the context node that you added the attribute to, and click 'Design'.

- In the 'Design' list, click 'New Entry'.

- Enter in the 'Attribute Name' field the name of your attribute, but leave all other fields blank (see image). Ignore the warning that pops up by clicking OK.

- Your attribute will now be available in the customizing screen in the web UI.

Regards,

Jonathan

Former Member
0 Kudos

Hello DNR ,

   http://scn.sap.com/thread/3164201 try this if you are still facing the problem .

Thanks and Regards ,

Nikhil Kulkarni

Former Member
0 Kudos

HI

Please follow the path and check this setting

SAPCRM->UIFRAMEWORK->DESIGN LAYER->DEACTIVATE OF HIDING FIELDS

Thanks & Regards,

Sivaram

kavindra_joshi
Active Contributor
0 Kudos

Extend using AET instead of manually adding the field.