Application Development Discussions
Join the discussions or start your own on all things application development, including tools and APIs, programming models, and keeping your skills sharp.
cancel
Showing results for 
Search instead for 
Did you mean: 

Which features of opensql are supported by sap 5.0?

former_member579349
Participant
0 Kudos

I mean there are couple of new things and I understand that it will not be possible to list all of them. So i just want to make sure that 5.0 supports escape character"@".

I checked and it's not working in SAP version 5.0. But I am working on CDS views and to use those latest features I have to use open sql's latest syntax.

I understand CDS views are not supported in SAP version 5.0 itself .

But I want to ignore the case of writing two FMs : one for 5.0 and one for 7.5 .

Please let me know if it is possible to write a FM which will work on both versions.

1 ACCEPTED SOLUTION

Jean_Sagi
Participant
0 Kudos

What you mean by SAP 5.0? ABAP? Netweaver?

All in all, go to the ABAP Keyword documentation (ABAPHELP). Best use your "7.5" sap system which is most up to date.
In the ABAPHELP expand the node "ABAP - Release - Specific Changes". You won't see a 5.0 version. It jumps from release 4.xx to 6.xx.

But lets say that you look into the "Changes in Release 6.20" there is no trace of escape characters in the documentation in fact as far as I know they got introduced in ABAP since 7.4 SP05 I think...

So, I think, that the answer is *NO*.

But you can check by yourself or maybe other here have some comments about.

I mean you are trying to use very latest features with an older SAP system. Maybe that is an *upgrade* opportunity but that can be a major challenge.


J.

1 REPLY 1

Jean_Sagi
Participant
0 Kudos

What you mean by SAP 5.0? ABAP? Netweaver?

All in all, go to the ABAP Keyword documentation (ABAPHELP). Best use your "7.5" sap system which is most up to date.
In the ABAPHELP expand the node "ABAP - Release - Specific Changes". You won't see a 5.0 version. It jumps from release 4.xx to 6.xx.

But lets say that you look into the "Changes in Release 6.20" there is no trace of escape characters in the documentation in fact as far as I know they got introduced in ABAP since 7.4 SP05 I think...

So, I think, that the answer is *NO*.

But you can check by yourself or maybe other here have some comments about.

I mean you are trying to use very latest features with an older SAP system. Maybe that is an *upgrade* opportunity but that can be a major challenge.


J.