Application Development Discussions
Join the discussions or start your own on all things application development, including tools and APIs, programming models, and keeping your skills sharp.
cancel
Showing results for 
Search instead for 
Did you mean: 

Unable to select GuiTab

ehru
Member
0 Kudos

Hello everyone!

I'm very new to sapgui and have been struggling to select a GuiTab in MM03 transaction. Selection works completely fine with a vbs script but the Python equivalent code doesn't work.

Sapgui version: 800 Final Release - 32bit

Python version: 3.10.9 64-bit

Here is a screenshot of the tabs I would like to select:

Here is the Python code that should select a tab:

This method receives the following arguments:tabstrip locator and a text of a tab that should be selected. This method is run by Robot Framewort in a for loop. All the arguments are correct.

I have tried to select the tab with both selecting it with locator and object itself but nothing get's selected. There isn't any error message. I also tried to get the tab object from tabs with ElementAt which worked fine but didn't change anything.

All the arguments / locators printed by this method and Robot Framework are correct and have been checked with Scripting Tracker.

Vbs script made by recording works without any problems:

I also attempted to copy this script to Python like so:

This also didn't select anything or generate an error.

Any suggestion are welcome, and I thank anyone beforehand for their time in helping me.

0 REPLIES 0