Application Development Discussions
Join the discussions or start your own on all things application development, including tools and APIs, programming models, and keeping your skills sharp.
Showing results for 
Search instead for 
Did you mean: 

transport request with table definition doesn't transport data in the table

Former Member
0 Kudos

Hello SAP gurus

I am trying to create a transport request which consists of a Z-Table with proper data elements, domains etc., defined. When I imported them on a different server, I am able to see all the definions including the table, data element, domain from the other server. However the table comes up as blank and thereby expecting me to populate the data from scratch (by manual entry or BDC method etc.,)

Am I doing something wrong? How can I transfer the table and other definitions along with the Data from one server to another.

Your help will be appreciated.




Active Participant
0 Kudos

Hi Ram,

Go to transport organizer (SE10). Select your request and double click on the request and then select objects tab.Now add one more row and enter R3TR TABU <your table name> and click enter. Double click on this newly created entry which will be redirected to add key fields of the table screen. Add all your key fields or simply * to select all data and save the request.Hope this helps.

Thanks & Regards,


Active Contributor
0 Kudos

plz chk the following link for transporting table entries:

U can search in SCN. u hve lot of posts reg the same.

0 Kudos

Hello Friends

I have read the links and followed the instructions and tried to create object

TABLENAME R3TR TABU and tried to save it.

I keep getting a warning message

Note: ZTABLE1 is an application table

Object TABU ZTABLE1 has object function "k", but no key.

(I don't know what key to enter. I tried the Key field name, but it said 'Enter Numeric values only').

If I ignore and save and try to create transport request and then import it on a different server, again only table structure is getting transported and not the contents/data of the table.

I would appreciate if some one can please let me konw what I am doing wrong.



Edited by: Ram Prasad on Jun 2, 2009 3:38 PM

Edited by: Ram Prasad on Jun 2, 2009 3:40 PM

0 Kudos

You must maintain a key, even if you only put "*" into the first field (means all entries), but you should at least fill the client.

Double click on the R3TR TABU line inside the transport request to maintain the keys. Kalyan explained this already.


0 Kudos

Thanks Thomas for the quick response.

Yes I tried Kalyan's suggestion of using *. Yes it didn't give the warning message but didn't send any data which I have entered in the table. That was the reason I tried putting the field name 'alpha numeric' but got a message that it has to be only numeric. So I didn't understand what exactly is this. Is it not the key fields that I have defined in the table that I am trying to transport?

Your help will be highly appreciated.

0 Kudos

What is the primary key of your application table, all field names and formats please.

The warning for "application table" makes sense, normally these entries are not being transported.

The problem you have with entering the key values is a mystery to me so far.

> Is it not the key fields that I have defined in the table that I am trying to transport?

No, it is the table entries that you want to transport, specified through primary key field values (can be wildcards).


P.S. /people/community.user/blog/2007/01/07/transport-table-entries

Former Member
0 Kudos

I followed Kalyan's suggestion. However, this didn't solve the issue completely. So after trying out few more times, I got a workaround.

I created a transport request with table definition, domain, data elements etc. (structure). and then created a separate transport request for just the table content (as per Kalyan's suggestion). Then imported these two requests on the other server to see the right table content etc.,

Thanks for all the responses.