Application Development Discussions
Join the discussions or start your own on all things application development, including tools and APIs, programming models, and keeping your skills sharp.
Showing results for 
Search instead for 
Did you mean: 

TD 600 Text * ID * language * not found in BAPI_PO_CREATE1

Former Member
0 Kudos


iam creating PO using BAPI_PO_CREATE1,

iam working on end to end implementation project, as i mentioned above iam getting error in return table as text ID language not found

when iam executing same BAPI using SE37 also iam getting same error.

what is the solution for this. i have searched threads but iam unable to resolve.

please helpme in this.

here iam attaching code.

pohead-DOC_TYPE = IT_TAB-bsart.
          pohead-COMP_CODE = it_tab-BUKRS."'IN99'.
          pohead-PURCH_ORG = it_tab-ekorg."'INPO'.
          pohead-PUR_GROUP  = it_tab-ekgrp." 'ESG'.
           pohead-CREAT_DATE = SY-DATUM.
          pohead-ITEM_INTVL = '00001'.
          pohead-DOC_DATE = SY-DATUM.
          pohead-vendor = IT_TAB-lifnr.

**************************  POHEADERX************************************

          poheadX-DOC_TYPE = 'X'.
          poheadX-COMP_CODE = 'X'.
          poheadX-PURCH_ORG = 'X'.
          pohead-CREAT_DATE = 'X'.
          poheadX-PUR_GROUP  = 'X'.
          poheadX-ITEM_INTVL = 'X'.
          poheadX-DOC_DATE = 'X'.
          poheadX-vendor = 'X'.

* *******************POITEM*************************************************
           COUNT = COUNT + 1.
           item-PO_ITEM = COUNT.
           item-TRACKINGNO = IT_TAB-BEDNR.
           item-PREQ_NAME = IT_TAB-AFNAM.
           item-PREQ_NAME = IT_TAB-AFNAM.
           item-SHORT_TEXT = IT_TAB-TXZ01.
           item-MATERIAL = IT_TAB-matnr.
           item-Plant  = 'IN99'.
           item-ACCTASSCAT = 'A'.
           item-QUANTITY = IT_TAB-menge.
           item-PO_UNIT = IT_TAB-MEINS.
           item-FUND     = IT_TAB-GEBER.
           item-FUNC_AREA_LONG = IT_TAB-FKBER.
           item-FUNDS_CTR = IT_TAB-FISTL.
           item-MATL_GROUP = it_Tab-matkl.
           V1 = IT_TAB-MENGE.
*      **********************POITEMX***************************

           itemx-PO_ITEM = COUNT.
           itemx-PO_ITEMX = 'X'.
           itemx-TRACKINGNO = 'X'.
           itemX-PREQ_NAME = 'X'.
           itemx-PO_ITEMX = 'X'.
           itemx-SHORT_TEXT = 'X'.
           itemx-MATERIAL = 'X'.
           ITEMX-PLANT = 'X'.
           itemX-STGE_LOC = 'X'.
           itemx-QUANTITY = 'X'.
           itemX-PO_UNIT = 'X'.
           ITEMX-NET_PRICE = 'X'.
           ITEMX-TAX_CODE = 'X'.
           itemX-FUND     = 'X'.
           itemX-FUNC_AREA_LONG = 'X'.
           itemX-FUNDS_CTR = 'X'.
           itemx-MATL_GROUP = 'X'.

*   ******************************* POSCHEDULE**************************
           sch-PO_ITEM = COUNT.
           sch-SCHED_LINE = '0001'.
           sch-DEL_DATCAT_EXT = 'D'.
           sch-DELIVERY_DATE = IT_TAB-LFDAT.
           sch-QUANTITY = V1.
          append sch.
          clear sch.

         schx-PO_ITEM = count.
         schx-SCHED_LINE = '0001'.
         schx-PO_ITEMX = 'X'.
         schx-SCHED_LINEX = 'X'.
         schx-DEL_DATCAT_EXT = 'X'.
         schx-DELIVERY_DATE = 'X'.
         schx-QUANTITY = 'X'.
append schx.
clear schx.
APPEND item.




Former Member
0 Kudos


try to put a break point in FM SAVE_TEXT and try to see what code is trying to create that text.


0 Kudos

Check the data in your bapi parameters POTEXTHEADER and POTEXTITEM.

- Puneet

0 Kudos

solved myself.

0 Kudos

Hey man!

Please, Could you explain your solution?

0 Kudos

Hi Shiva,

It would be a great help if you let us know, how you managed to correct it ?

I also have some type of issue and I am not able to create PO for the Contract Agreement.

0 Kudos

Hi Shiva,    Can you tell us how did you solve this issue ??

0 Kudos

Hi All,

  we are also got same Problem. we resolve this problem by passing the  POHEAD- CURRENCY         =    'USD'.

it is working fine.

Thank you,


0 Kudos

does any one have solution for the error"" text * id * language * not found"" in BAPI_PO_CREATE1.


Former Member

Please make sure the Purchasing Document Type (BSART) you are using exists in the system, it seems to be an error message that does not have the correct translation instead of returning "Invalid Document Type"

0 Kudos

We also had the problem. BSART was incorrect (O instead of 0 in one character). Once BSART is correct, error disappeared. the RETURN message is obviously missleading.

0 Kudos

This is because Document type you are trying to pass is not available in the system. If add the Document type it will be resolved.

0 Kudos

Hi everyone ,today, when testing inbound PORDCR103 IDOC via WE19 ,im also suffering this error,

the background is: this is an IDOC interface which is already go-alive, i have not change any input to BAPI_PO_CREATE1, but just add some new check logic; so suppose shall not be input issue;

so when during numbers of debug with WE19,there's a symptom:

if u don't exit WE19 between 2 sending, then the internal table in the inbound FM will not be cleared!!!

which will absolutely cause the BAPI_PO_CREATE1 executeing error; bloody hell....

so u just need to exit WE19 or '/N' between two IDOC sending to avoid this.