Application Development Discussions
Join the discussions or start your own on all things application development, including tools and APIs, programming models, and keeping your skills sharp.
cancel
Showing results for 
Search instead for 
Did you mean: 

tcode for the zreport

Former Member
0 Kudos
170

t-code FGI3 , there are several reports , i created 1 zreport and wants to create the tcode .

Tcode SE93 , and i created the tcode as trans report (added the program name and the screen number )

Now the issue is when i run the tcode , there are 3 divisions , the 2 divisions are exactly as it is in the zreport but the 3rd part which should say "output types" is different and has different data all together.

Can anybody throw some light on it . How do i get the report from tcode exactly the way it is in the zreport .

Help will be appreciated .

Sumit

Edited by: sumit123 on Feb 15, 2010 10:13 AM

5 REPLIES 5

Former Member
0 Kudos
67

Sorry its difficult to understand your question. What do you mean by 3 divisions? what does FGI3 have to do with your zprogram?

0 Kudos
67

okay, i reframe my question .

i created a tcode for the zreport and it is not displaying all data as it should display .

there are 2 ways of reaching the report .

1) tcode FGI3(there are several reports here ) and then select the zreport and click execute , but we do not want to give this path to users , instead we want to give the tcode for the zreport

2) the other way to reach the report is by the tcode that i created .

The issue is tcode does not display the entire data .

Sumit

Edited by: sumit123 on Feb 15, 2010 10:35 AM

neelavraj_duara2
Explorer
0 Kudos
67

FGI3 looks more like a collection of Reports created through report writer. If that is the case, please check the details of output fields as maintained in the report painter/writer and ensure the same is there in your Z Program.

Hope this helps.

0 Kudos
67

Hello Neelav ,

when i check the output type is the zreport throgh FGI3 , it is classic drill down selected and also "available on selection screen " option ticked .

Where do i check in my zreport program .

is there any call function ....

guys pleassssssssssssssssse help ..................it is important

Sumit

Edited by: sumit123 on Feb 15, 2010 1:12 PM

Former Member
0 Kudos
67

Hi

My suggestions is if it is report painter generated report then ask FI consultant to regenerate and activate.

Else you may need to debug /h just befor the point where you thibk the data goes missing.

Regards

Gaurav