Application Development Discussions
Join the discussions or start your own on all things application development, including tools and APIs, programming models, and keeping your skills sharp.
cancel
Showing results for 
Search instead for 
Did you mean: 

Tag "tableView" contains invalid attribute values.

Former Member
0 Kudos

Hi,

I'm working my way through the BSP extension examples in the WAS programming book, and keep getting the following error every time I use the tableView extension:

<HTMLB:tableView>: (Attribute=columnCount) The attribute does not exist. (Compile time validation error).

Tag "tableView" contains invalid attribute values.

The error occurs even when I try to activate one of the built-in example BSP applications in the miniBSP. Is it my installation that lacks something, or is this a known error?

I'm on XP Pro, Explorer 6, miniBSP (6.20)...

trond

1 REPLY 1

dirk_feeken
Advisor
Advisor
0 Kudos

As always s... strange things happen in the last minute and when providing the Mini SAP system a serious bug entered it shortly before the CDs have been pressed.

(For those with OSS access the solution is described in Note 621674)

Here's how to proceed:

Edit the method INITIAL_CHECKS of the class CL_BSP_ELEMENT_CT_ATTR_VALID

and delete following three three lines:

IF attribute_info IS INITIAL.

   me->Error( name = name msg = 'Der Attribute existier nicht. (Compile Time Validation Error)'(009) ).

ENDIF.

You will be asked to create a transport request for this modification (do it) . Don't forget to activate the changed class!

Restart the se80 and activate the whole BSP application again. Then it works.

Its probably a good idea to release the created transport request (se09).

best regards,

Dirk