Application Development Discussions
Join the discussions or start your own on all things application development, including tools and APIs, programming models, and keeping your skills sharp.
cancel
Showing results for 
Search instead for 
Did you mean: 

table is aking for customizing request when we try to save data

Former Member
0 Kudos

Hi All,

I have a custom table.For this I have table maintanence generator also created for that.

When I try to enter the data and save that,it is asking for customizing request.

But I dont want that request to be created.

Please help me with possible solutions.

Regards,

Akanksha

7 REPLIES 7

Former Member
0 Kudos

Hi !

You should do the following:

Go to the SE11 and there to the "Table Maintainence Generator".

Set the "Dialog Data Transport Details" to

"no, or user recording routine".

Save an generate the new settings.

That shuld help you !

Regards

Rainer

Some Forum points would be fine if that helped you solving your problem...

athavanraja
Active Contributor
0 Kudos

check the delivery class,(attributes of the table deliverymaintenance tab) you should have mentioned it as "C" or "G" customizing table

Regards

Raja

Former Member
0 Kudos

Hello Akanksha,

In the table attributes tab, check the checkbox - 'Table Maintenance Allowed'.

This should allow you to create data without asking for a request.

Vaishali

0 Kudos

switch off the standard recordsin routine in table maintenance..

Suresh

Former Member
0 Kudos

Hi,

if its delivery class is "customizing table" it always asks for customizing request.Is it a customer table ( starting with Z )?if the answer is yes u can change its delivery class to "application table".Go to se11 , write your table name, press change , on the "Delivery and maintenance" tab change the delivery class to A ( appl.table ) from C ( cust. table ).It wont ask again.

regards,

Burak

Former Member
0 Kudos

Hi,

pls check the delivery class of ur table.

Make it <b>application table</b>- A and chek again.

Regards,

Anjali

Former Member
0 Kudos

Goto SE11-> Table maint gene-> in this select recording routine to NO, or USER, RECORDING routine. Thisshould solve ur problem.