Application Development Discussions
Join the discussions or start your own on all things application development, including tools and APIs, programming models, and keeping your skills sharp.
Showing results for 
Search instead for 
Did you mean: 

SUIM issues after EHP5 upgrade

Active Participant
0 Kudos

Hi Experts,

I am facing issues with SUIM results whenever i am searching for roles with transaction,roles with authorization.

I am selecting single role.composite roles with valid user assignment.

In roles with complex criteria with tcode i am getting 3000 roles and when i provide the same tcode in s_tcode getting soem 22 results.

We need to use it frequently to assign role to users based on tcode but now some time the result roles are not correct.

In the results in opened one role and that doesn't have that tcode.

I checked threads

all these threads have good information but my issue is still not solved by the SAP notes mentioned in these threads.

SAP ERP 6.0 EHP 5 SAP Basis 702 SP 007.

Any pointers in this regard are highly appreciated.




Active Contributor
0 Kudos


if you can't find OSS note that address your problem that maybe just grabbing ABAP developer and debugging transaction will be the fastest way to figure why it does not work.


Active Contributor
0 Kudos

Or simply knock service market place


Arpan Paik

Active Contributor
0 Kudos

Hi Ajay,

I hope you are considering below senarios while pulling extracts:

1. SUIM --> role by Tcode

It will give output for roles (single as well as composite) including perticulter Tcode.

Also it includes roles including Tcode via Menu and S_Tcode object

2. Suim --> Role by object S_Tcode value=Tcode

it will give output for the Single roles only as it contains actual S_Tcode object and will not output composite roles


0 Kudos

Hi Rupali,

Thanks.With SUIM ->Role by Transaction assignment now i am getting correct data.The thing is that its a new Y tcode and yesterday it was not at assigned to any role.So i was getting some 3000 as results yesterday.Strange.

Anyway,for SUIM Roles by Complex search criteria without user assignment No result/no role whcih should be OK

Same thing wiht user assignment 1 result which is also Ok

But instead of Transaction code if i choose authorization object s_tcode and then value Y tcode with valid user assignment i am getting 23 roles including the correct one. Other 22 role don't have this tcode.

Why the results are varying.What is wrong here??



0 Kudos

If I wouldn't have the same issue right now I wouldn't bother. But simple search in the notes database gave me pretty good candidate for the issue. 1575598.

Active Participant
0 Kudos

Solved the issue