Application Development Discussions
Join the discussions or start your own on all things application development, including tools and APIs, programming models, and keeping your skills sharp.
cancel
Showing results for 
Search instead for 
Did you mean: 

Subscreen

Former Member
0 Kudos
165

I have activated one subscreen in enhancement ITOB0001 and place a new field in it. This new field is equi-eqber. I am able to enter the data for that field via tranx IE02 and update this value in the database. However, I am not able to display this field so when trying to display or change, the value show up in that field is blank. How do I go about displaying the value for that field in this subscreen? Before calling this subscreen, I have visibility to the data for table EQUI. When in the subscreen processing, I don't know which table to extract this same data from. Please advise.

Thanks,

Ravi

8 REPLIES 8

Former Member
0 Kudos
79

You need to write the code to update custom field in one of the function exit..

Check the below document and see the subscreen documents :

http://wiki.ittoolbox.com/index.php/Implement_a_screen_exit_to_a_standard_SAP_transaction

Thanks

Seshu

0 Kudos
79

the problem is I don't know what table has the data to pass to this custom field. Is there a way to track which table?

Former Member
0 Kudos
79

Hi,

If the new field you are adding is related to equipment master data EQUI. Then you have to append a new structure to this table and include this field. when you use IE01 or IE02 after the user enters a value in the subscreen and saves it, you have to find an exit and store your this value in the append structure of EQUI.

and in the display mode find another exit to retrieve this value from the new field and display it in the screen.

Thanks.

Message was edited by:

mg s

0 Kudos
79

The new field is new to the subscreen only. It's an existing field in table EQUI.

0 Kudos
79

If its an existing field then you dont have to append a structure to EQUI you have populate this field in an exit.

Otherwise its the same process. The main thing is you have to find the right exit which will update this field in EQUI from the screen during create and change & retrieve value from the table to the screen during display.

0 Kudos
79

I think you have to name the field correctly ... In that case it will automatically get saved in the EQUI I guess. Please check that.

Message was edited by:

mg s

former_member194669
Active Contributor
0 Kudos
79

Hi,

while saving the document switch on the trace, and check whether value is flowing to table properly or not.

for trace use tranx ST05

aRs

Former Member
0 Kudos
79

Hi Ravi i am facing the same problem in my case its a z field, i have placed it in SAPLXTOB 1000 screen and able to enter the value in IE01 & populate it in the EQUI table but couldn't display it in IE03. if you have found out how to do it pls tell me.