Application Development Discussions
Join the discussions or start your own on all things application development, including tools and APIs, programming models, and keeping your skills sharp.
cancel
Showing results for 
Search instead for 
Did you mean: 

Spool in sp01 is Waiting even after its completed

Former Member
0 Kudos

Hi,

I have made changes to a smartform triggering from a Tcode.

The program generates the Form and iam able to see the preview in SP01 Spool.

But the Spool request is always in  'waiting state' even after its completed.

Please let me know what is causing this and how to fix it,

5 REPLIES 5

venkateswaran_k
Active Contributor
0 Kudos

Hi Aarthi

While calling the  smartform,  there is a table parameter called nast.

before calling the form    set the value nast-DELET = 'X'

is_nast              = nast          Regards, Venkat

Former Member
0 Kudos

Hi Aarthi,

I have faced similar issues, when i gave wrong logical destination or printer etc in my driver program. Please check the printer associated with your ECC and give it correctly.

BR.

arindam_m
Active Contributor
0 Kudos

Hi,

In SP01 check the details of why it is in Waiting status and also "Frontend unavailable" as Status Text as you might be using Frontend Printing access method. You might have to change the output device access method in SPAD. Check the link below for details on access methods available.

help.sap.com/saphelp_nw70/helpdata/en/21/41e3e7a9d8c54bb360f628d4525838/frameset.htm

Cheers,

Arindam

Sriram2009
Active Contributor
0 Kudos

Hi Aarthi Kumar

  As mention in the below screen shot check the user profile default tab check the option "output immediately" and then try for printouts

Thanks

Sriram

former_member184569
Active Contributor
0 Kudos

Confirm if you have a Printer at your local machine which is set as Default Printer.

Sometimes, it may be due to an overflow of spool requests and you may need to clear your old spool requests.

What are the details provided when you click on the waiting status?