Application Development Discussions
Join the discussions or start your own on all things application development, including tools and APIs, programming models, and keeping your skills sharp.
cancel
Showing results for 
Search instead for 
Did you mean: 

Smartforms testing

Former Member
0 Kudos
1,607

hi,

i am new to smartforms. I've been trying to test the smartforms output.

If I don't want any application data, then there is no need of driver program.(correct me if i am wrong)

If i am trying to print only static data in the form,

then how to test that SF?Can somebody tell me the procedure?

7 REPLIES 7

RichHeilman
Developer Advocate
Developer Advocate
0 Kudos
338

There is a "test" button on the first screen of the "SMARTFORMS" transaction.

Regards,

Rich Heilman

0 Kudos
338

Or call your function with the transaction SE37.

(in the menu of the transaction SMARTFORMS you could find the name of the function module)

Message was edited by: Frédéric Girod

0 Kudos
338

After clicking on test button it is taking me to se37 screen giving a function module name.If I execute that function module,it is not showing any print preview.

If I take a simple thing that In a window I'll take some address(static). That should be shown in print preview..right? But I am not getting that...Plz help me out in this problem..Then only I can go ahead with my object..

0 Kudos
338

In function module:

first it ask you parameters for your function module.

second ask you to print or print-preview.

third print or print the print preview.

If that doesn't work you could have an error message in the screen.

0 Kudos
338

It is throwing FORMATTIN_ERROR Exception. But when I check and activate my form it didn't show any error..

What might be the problem?

0 Kudos
338

Just for testing purposes, take a standard smartform such as "SMART_FORM_PPF" and click the test button, this will take you to the generated function module, click test. Click execute. Do you get a "print/printpreview" popup screen? If you are not getting this from your custom smartform, then something is not right in your smartform. Try, putting a literal in the smartform, something like "TEST" in the middle of the page, and try again.

Regards,

Rich Heilman

0 Kudos
338

There could be a lot of reason for your error.

Do you use template ?