Application Development Discussions
Join the discussions or start your own on all things application development, including tools and APIs, programming models, and keeping your skills sharp.
Showing results for 
Search instead for 
Did you mean: 

Selection screen refresh

Former Member
0 Kudos


my question here is related to selection screen refresh.

in the program one parameter is defined like below.


In the table YFR1FIT_SALE_REF table the field POST_CODE the values were maintained at domain level. So, when i selected the F4 help on this field, all the domain values are appearing in the pop-up and also the validation of the data.

Now i have changed that, instead of domain, i have given the check table for this field. Though i did this change at table level, it looks these changes are not reflecting in the program. The program still showing the values maintained at the domain level, but not from the check table.

When i went to SE51 and given this program and 1000 as screen no, i noticed that the flow logic is not updated as per the latest changes. its still refering to the domain level values for validation..

So, to overcome this problem, it looks i have to update the flow logic of the screen 1000, which is created by default. Do you have any idea on how to correct this or refreshing the flow logic for the screen 1000.

Thanks for your time.




Former Member
0 Kudos

As per [Input Help Hierarchy in the ABAP Dictionary|] Check Table should have overridden the Domain Values in search help.

Please try to activate the screen 1000 (you can go through SE80) once again. Ihave faced such problem earlier.

But even if the problem persists check if you need to insert TABLES statement.. just dicing a though if it works.

You can paste the code also.

0 Kudos

Thanks Amit for your response.

I already tried activating the screen in SE51/SE80, but its of no change. The earlier code still not overwritten with Check table logic. But when we transported this program to Quality, its working fine. i mean, the validation is happening with the check table only and domain values are not feching...

This problem i have only in dev environment.