Application Development Discussions
Join the discussions or start your own on all things application development, including tools and APIs, programming models, and keeping your skills sharp.
cancel
Showing results for 
Search instead for 
Did you mean: 

regarding unicode problem

Former Member
0 Kudos

Hi friends,

Iam converting report programs from 4.6 to ECC 6.0.

Error:

The type of database table and work area (internal table) I_TAB are not unicode convertible.

Statements:

table declaration:

DATA: BEGIN OF I_TAB OCCURS 100,

MANDT TYPE ZJE_AUDIT-MANDT,

BUKRS TYPE ZJE_AUDIT-BUKRS,

BELNR TYPE ZJE_AUDIT-BELNR,

GJAHR TYPE ZJE_AUDIT-GJAHR,

BUZEI TYPE ZJE_AUDIT-BUZEI,

BUDAT TYPE ZJE_AUDIT-BUDAT,

CPUDT TYPE ZJE_AUDIT-CPUDT,

SAKNR TYPE ZJE_AUDIT-SAKNR,

BLART TYPE ZJE_AUDIT-BLART,

BSCHL TYPE ZJE_AUDIT-BSCHL,

GSBER TYPE ZJE_AUDIT-GSBER,

SGTXT TYPE ZJE_AUDIT-SGTXT,

DMBTR TYPE ZJE_AUDIT-DMBTR,

USNAM TYPE ZJE_AUDIT-USNAM,

TCODE TYPE ZJE_AUDIT-TCODE,

R_USNAM TYPE ZJE_AUDIT-R_USNAM,

XBLNR TYPE ZJE_AUDIT-XBLNR,

R_GJAHR TYPE ZJE_AUDIT-R_GJAHR,

AMOUNT(15),

END OF I_TAB.

SELECT * FROM ZJE_AUDIT INTO TABLE I_TAB

WHERE BUKRS EQ P_BUKRS

AND GJAHR EQ P_GJAHR

AND BUDAT IN S_BUDAT

AND SAKNR IN S_SAKNR.

How to rectify this unicode problem.

Pl help in this regard,

Thanks,

vamsykrishna

1 ACCEPTED SOLUTION

Former Member
0 Kudos

Change the selection to:



SELECT * FROM ZJE_AUDIT INTO CORRESPONDING FIELDS OF TABLE I_TAB
WHERE BUKRS EQ P_BUKRS
AND GJAHR EQ P_GJAHR
AND BUDAT IN S_BUDAT
AND SAKNR IN S_SAKNR.

Regards,

John.

3 REPLIES 3

Former Member
0 Kudos

Change the selection to:



SELECT * FROM ZJE_AUDIT INTO CORRESPONDING FIELDS OF TABLE I_TAB
WHERE BUKRS EQ P_BUKRS
AND GJAHR EQ P_GJAHR
AND BUDAT IN S_BUDAT
AND SAKNR IN S_SAKNR.

Regards,

John.

0 Kudos

Hi,

you can try with create internal table body and work area by using TYPES..

other wise in the select quirey in INTO clause use INTO CORRESPONDING FIELDS OF TABLE.

Regards

Sriram.

former_member182346
Active Contributor
0 Kudos

hi

go to se38

select the attributes radio button

click change button

now look at the "Unicode check active " ststus. Unchecked it.

Hope this ll be helpful.

Thanks & Regards

vinsee