Application Development Discussions
Join the discussions or start your own on all things application development, including tools and APIs, programming models, and keeping your skills sharp.
cancel
Showing results for 
Search instead for 
Did you mean: 

QUANTITY FIELD IN MODULE POOL

Former Member
0 Kudos

Hi all,

I AM HAVING A QUANTITY FIELD IN TABLE CONTROL OF MODULE POOL PROGRAM.

I WANT THE QUANTITY FIELD TO HOLD A QUANTITY OF 0.000

WHEN I GIVE A VALUE OF 0 , ITS NOT HOLDING .

CAN ANYONE SUGGEST ME AS TO WHAT I NEED TO DO.

I AM USING MENGE_D STANDARD DATA ELEMENT.

THANKS

8 REPLIES 8

Former Member
0 Kudos

I dont see a reason why it should not hold the value. At the begining the field is initialised and so it will hold a 0.000 in there. And later if you are modifying it, it should also have a 0.00 in it unless you have not cleared the work area before and making this change. Please check that.

- Guru

Reward points for helpful answer

0 Kudos

Hi,

while debug it has a vlue of 0.000 but for some reason its not displayed on the screen.

LET ME KNOW

THANKS

0 Kudos

OK..the reason it is not being displayed is because it is initial. You can do one thing. Declare this field as NUMC in the output table. Then this value will be displayed.

- Guru

Reward points for helpful answer

0 Kudos

hi

YOU MEAN TO SAY IN THE TABLE CONTROL

Thanks

0 Kudos

yes.

- Guru

Reward points for helpful answer

0 Kudos

Hi,even the numc value is not displayed in the table control.

Thanks

0 Kudos

Try setting the checkbox "Leading zeroes" in the attributes of the field of your TControl (you can do that using transaction SE51 - Screen Painter).

0 Kudos

Set the field as character.

move the value to another variable while processing and check for decimal places in case a value other than 0 is input.

Regards,

Deepa