Application Development Discussions
Join the discussions or start your own on all things application development, including tools and APIs, programming models, and keeping your skills sharp.
cancel
Showing results for 
Search instead for 
Did you mean: 

Program and ABAP Debugger taking time....

Former Member
0 Kudos
186

hi guys,

I want to debug certain programs. But the problem is after "/h" ABAP debugger is taking undefinate time to start.

"ABAP Debugger is starting...."

Even i can open program because same reason. Only waiting clock is displaying.

Did i have to make any setting in my SAP or server setting of SAP.

10 REPLIES 10

Former Member
0 Kudos
105

How many sessions you had opened while u try to debug?

Is it custom tcode or standard?

-Sowmya

Former Member
0 Kudos
105

Hi Sowmya,

Its only one session and irrespective of tcode, its taking time for both standard and custom.

0 Kudos
105

Quick solution : Use the classic debugger... ! Old but handy !

Former Member
0 Kudos
105

Hi ,

May be issue with your new debugger ,

Try

SE38 -> Utilities -> Settings -> ABAP Editor -> Debugging -> ABAP Debugger -> Classic Debugger.

Hope it works...

Thanks

~Raj

0 Kudos
105

Yes its working with classic debugger, but new debugger is not opening. Even program is only opening when i am using front editor as old.

0 Kudos
105

Yes its working with classic debugger, but new debugger is not opening. Even program is only opening when i am using front editor as old.

0 Kudos
105

Hi Rahul,

is your SAPGUI Frontend up to date? Maybe it has the wrong version ?

Regards,

Dirk

0 Kudos
105

hi dirk

its updated version only.

0 Kudos
105

Hi Dirk,

its updated version only.

0 Kudos
105

Hi Rahul,

Anything which you run in SAP for the first time takes longer. (Compiling/generation/Executable and stuff). Maybe you just have to give it some time. See if the problem is only with you or with other users as well? Finally report to your Basis team.

Regards,

Shravan