Application Development Discussions
Join the discussions or start your own on all things application development, including tools and APIs, programming models, and keeping your skills sharp.
Showing results for 
Search instead for 
Did you mean: 

Problem in Epson LX 300 II printing using arial font in 5.5in paper size

Former Member
0 Kudos

I've created a page format ZVOUCHER (Portrait width of 215MM and 140MM) and a format type ZVOUCHER using the page format I've created. I've tried device types using EPESCP2 and EPESCP9 but the printing out only contains <i>APWIN%Cbp1s1P92,1440;</i>.

When I used SWIN, arial is ok but the paper ejects in the usual way, like the letter size. I can't figure out how to set up the printer initialization properly. I've just inputted the codes.

<i># reset


  1. set line spacing 6 LPI


  1. set page length (33)



Active Contributor
0 Kudos


In SPAD you need to create the Device type & then the page format should be created for that specific Device type.

Best regards,


0 Kudos

Hi, Prashant! The ZVOUCHER page format is already in the device type SWIN, EPESCP2 or EPESCP9 but the print out is still not correct.