Application Development Discussions
Join the discussions or start your own on all things application development, including tools and APIs, programming models, and keeping your skills sharp.
cancel
Showing results for 
Search instead for 
Did you mean: 

Problem facing during running the session of xd01 transaction

Former Member
0 Kudos
100

We are doing recording of the XD01 transaction through LSMW. In screen 120 one custom tab is there. During recording, control is going inside that tab. However, while running the session, the control does not go inside and it throws an error like

"No batch input data for screen SAPMF02D 0120".

Kindly guide us ASAP...

Thankyou very much in advance anticipating your quick positive help.

Sudipta

8 REPLIES 8

Former Member
0 Kudos
60

Hi Sudipta.

recording won't work for custom tabs. try to use BAPI

Reg,

Kishore

0 Kudos
60

Hi Kishore,

For custom tab how to use a standard BAPI. Please give me the steps.

Thanks & Regards

Sudipta

0 Kudos
60

Hi Sudipta,

use this bapi

BAPI_CUSTOMER_CREATEFROMDATA1

BAPI_CUSTOMER_CREATE

Former Member
0 Kudos
60

Dear Sudipta,

Please check the screen flow in record throught process and note screen flow.

some times ok buttons create mess.

Regards,

Vijay

Former Member
0 Kudos
60

Dear All

Waiting for some good fruitful input from you ASAP... We are using LSMW recording .

Thanks & Regards

Sudipta

0 Kudos
60

Hi,

The error will be coming due to some error on a previous screen.

Just try to run the session in foreground to check if any mandatory field needs to be passed.

Regards,

Ankur Parab

Former Member
0 Kudos
60

HI ,

Customer scrrens and field depends totally on ACCOUNT GROUP which is maintained in intial screen of XD01 transaction.

Code based on your Acoount group.

Please let me know if you still need any more help.

Thanks and regards,

Rajeshwar.

0 Kudos
60

Hi,

We are using LSMW recording. During recording the control is going inside the custom tab, but while running the session the control is not going inside the custom tab. This is the actual issue what we are getting. Kindly guide us at the earliest.

Thanks & Regards

Sudipta