Application Development Discussions
Join the discussions or start your own on all things application development, including tools and APIs, programming models, and keeping your skills sharp.
cancel
Showing results for 
Search instead for 
Did you mean: 

problem configure sapnwrfc

0 Kudos
947

Hi there,

I have successfully used php_saprfc.dll with WampServer 2.0b (Apache 2.2.8, PHP 5.2.5) on Windows server 2008. now I am upgrading to WampServer 3.1.4 (Apache 2.4.35, PHP 7.2.10) on Windows server 2016, the old php_safrfc.dll does not work anymore, so I am trying to use sapnwrfc. Building the sapnwrfc library from source is kind complicated for me, so I found some pre-built extensions for Windows (php_sapnwrfc-1.3.0-7.3.8-vc15-nts-x64.dll, php_sapnwrfc-1.3.0-7.3.8-vc15-nts-x86.dll, php_sapnwrfc-1.3.0-7.3.8-vc15-ts-x64.dll, php_sapnwrfc-1.3.0-7.3.8-vc15-ts-x86.dll, maybe not match my current PHP version, anyone can please provide a right version of prebuild extension? And also not sure if it’s the really issue, I also tried the newer wampsever which PHP is 7.3.12, does not work either). by some online information, seem I need the nwrfcsdk, so I got “nwrfcsdk_720” through our SAP technical guy, the following is how I trying to config it:

  1. I rename the prebuilt file "php_sapnwrfc-1.3.0-7.3.8-vc15-nts-x86.dll" to "php_sapnwrfc.dll", then copy it to "php\ext" folder. then update the php.ini file to have the extension set.
  2. copy the folder nwrfcsdk_720 to C driver, and rename it as "nwrfcsdk", then set environment PATH "C:\nwrfcsdk\lib",
  3. restart the windows server and apache server.

But the extension was not loaded, I check PHP log, here are the error:
[02-Jan-2020 21:53:03 UTC] PHP Warning: PHP Startup: Unable to load dynamic library 'sapnwrfc' (tried: c:/wamp/bin/php/php7.2.10/ext/sapnwrfc (The specified module could not be found.), c:/wamp/bin/php/php7.2.10/ext/php_sapnwrfc.dll (The specified module could not be found.)) in Unknown on line 0

What’s the problem here. Really hope someone help me on this to make it work.

Best regards,

2 REPLIES 2

0 Kudos
165

Have the same problem...

Please some should give us a suggestion.

0 Kudos
165

same for me