Application Development Discussions
Join the discussions or start your own on all things application development, including tools and APIs, programming models, and keeping your skills sharp.
cancel
Showing results for 
Search instead for 
Did you mean: 

Phase 21 of 24 - Installation Problem Netweaver 2004s Sneak Preview !!!!!

gksu_firat
Explorer
0 Kudos

SAP Netweaver 2004s Sneak Preview

ABAP Installation

At Phase 21 of 24 - Start Instance

2 Error MessegeBox Appears with texts I wrote below :

"igswd.EXE has encountered a problem and needs to close. We are sorry for the inconvenience."

"disp+work.EXE has encountered a problem and needs to close. We are sorry for the inconvenience."

These are standart windows execution problem windows.

After installation progress wain for 10 minutes to comunicate with something and

fails with a status bar messege :

"Starting NSP/DVEBMGS00 [ABAP: MSNOTRUNNING]. Elapsed time: 10:00 minutes .."

Then SAPinst gives me 3 choice

"Retry" , "View Log" and "Stop"

"Retry" does nothing as usual ..

At Log Browser :

there are too many log record that says :

"WARNING 2006-02-12 23:37:49"

"Connect to message server (blackhawk/3900) failed: NIECONN_REFUSED."

And I think more Important log record is:

"WARNING 2006-02-12 23:37:48"

"Execution of the command "C:\usr\sap\NSP\SYS\exe\nuc\NTI386\startsap.exe name=NSP nr=00 SAPDIAHOST=blackhawk" finished with return code -1."

"Output: STARTSAP failedDetails are written to C:\Program Files\sapinst_instdir\NW04S\LM\COPY\ADA\SYSTEM\CENTRAL\AS-ABAP\startNSP.log"

Sure I looked the "startNSP.log"

startNSP.log

-


running C:\usr\sap\NSP\SYS\exe\nuc\NTI386\sapstart.exe name=NSP nr=00 SAPDIAHOST=blackhawk -wait

SAPSTART finished successfully on blackhawk_NSP_00, but at least one process doesn't run correctly:

msg_server.EXE, MessageServer, Stopped, 2006 02 12 23:34:34, 0:00:03

disp+work.EXE, Dispatcher, Stopped, 2006 02 12 23:34:34, 0:00:51

igswd.EXE, IGS Watchdog, Running, 2006 02 12 23:34:34, 0:03:13

C:\usr\sap\NSP\SYS\exe\nuc\NTI386\sapstart.exe=>sapparam(1c): No Profile used.

-


I don't know what is the problem ?

I try a million times to install again but found no solution

Help me please !

Really don't know how I can solve that situation

try to install in my local network includes "WAG354G ADSL Home Gateway".

try to Install with loopback adapter only

nothing changes !!!!

I only want to work on TAW10 AND TAW12 ABAP COURSE exercise and examples on my computer locally.

Have any body has any brilliant idea to help me EXCEPT "SAP Netweaver 2004s" ?

It must not be as that difficulty ...

1 ACCEPTED SOLUTION

RichHeilman
Developer Advocate
Developer Advocate
0 Kudos

Lets try this...... on the desktop, there is an SAP MMC icon. Open that up and start the engine manually. Right click on the NSP node and select Start. After the instance is started, go back to the installation and continue where it left off. Hopefully it will finish successfully.

Regards,

Rich Heilman

5 REPLIES 5

RichHeilman
Developer Advocate
Developer Advocate
0 Kudos

Lets try this...... on the desktop, there is an SAP MMC icon. Open that up and start the engine manually. Right click on the NSP node and select Start. After the instance is started, go back to the installation and continue where it left off. Hopefully it will finish successfully.

Regards,

Rich Heilman

0 Kudos

Thanks for your advice my friend but I think that way does not solve the problem because I get same execution error again.After I try to start engine manually :

-msg_server.EXE cannot be started.

-disp+work.EXE started but still can not communicate with message server and fails absolutely 2 min.later

-igswd.EXE running.

????? what's wrong with that !!!!

0 Kudos

if you have any virus scan software is running, disable it and then continue the installation.

also check whether SAPDB:NSP services are running.

Regards

Raja

Proper forum for these kind of question is WebAS preview installtion at

0 Kudos

Firstly of all deactivating microsoft Anti-Spam Software

doesn't solve the problem.

"SAPDB:NSP" service running also

"SAPNSP_00"

"SAPOsCol"

"Xserver" services are running.

I look up "WebAS preview installtion" forums then:

1) for loop back adapter responding I edit my

c:\windows\system32\drivers\etc\hosts and add

"10.10.0.10 blackhawk" line.

also edit c:\windows\system32\drivers\etc\services and add

"sapmsJ2E 3601/tcp # SAP System Message Port"

"sapmsNSP 3602/tcp # SAP System Messaging Service Port"

lines.

2)Add Variables To Enviroment Variables:

- DBMS_TYPE ada

- PATH C:\sapdb\programs\pgm;C:\sapdb\programs\bin;

C:\sapdb\programs\env;C:\sapdb\programs\lib;

C:\usr\sap\NSP\SYS\exe\nuc\NTI386;

C:\sapdb\NSP\db\bin;

C:\usr\sap\NSP\DVEBMGS00\exe

- SAPEXE C:\usr\sap\NSP\SYS\exe\nuc\NTI386

- SAPLOCALHOST blackhawk

- SAPSYSTEMNAME NSP

3)Install The MaxDB Database manager and logon the NSP database as superdba its online and has 2.198,83 MB 24,00% free area. So it's not full.

So I read so much post but find no solution ...

Otherwise SAPMMC SYSTEMLOG want to say something with that messages I think :

#SAP-Basis System: Start Msg Server, 1 times since system startup. PID 2364

#SAP-Basis System: Operating system call getservbyname_ failed (error no. 0 )

#SAP-Basis System: Stop Msg Server, PID 2364

#SAP-Basis System: Buffer SCSA Generated with Length 4096

#SAP-Basis System: Start SAP System, SAPSYSTEM 00, Dispatcher Pid 5920

#SAP-Basis System: > 3 possible network problems detected - check tracefile and adjus

#SAP-Basis System: Signal c00 received by operating system

I just can say "dammed" ...

0 Kudos

i would suggest to first uninstall the whole stuff. now just follow carefully all the steps mentioned in the installtion guide availabe from the same location where you downloaded the NSP NW2004s.

Regards

Raja