Application Development Discussions
Join the discussions or start your own on all things application development, including tools and APIs, programming models, and keeping your skills sharp.
cancel
Showing results for 
Search instead for 
Did you mean: 

Order of Implicit Enhancements

VenuAnumayam
Participant
0 Kudos
792

Hi Experts,

I have created an implicit enhancement implementation in a sub-routine. There was an already existing implicit enhancement implementation at the same spot. I am trying to place my enhancement code before this. However it's not letting me to do it.

I tried: SE38 ->Enhance->Edit->Enhancement Operations->Show Implicit Enhancements->Create.

When creating my new implementation, it shows mine top of the existing implementation. However after activing my implemenation though, it places the code under the existing one.

What am I doing wrong? Please help.

Thanks.

3 REPLIES 3

Former Member
0 Kudos
161

Hi Ravi,

There's nothing wrong in your action. Actually implicit enhancements you can write only at the beginning or at the end of the standard program source code. It is not possible to insert our custom code in-between standard code in case of implicit enhancements.

You may search and use any BADI or user exit if possible to meet your requirement.

Hope this helps.

Regards,

Abhijeet Kapgate

former_member404244
Active Contributor
0 Kudos
161

Hi,

Instead of creating a new one why don't you use your code in the already existing enhancement.. Inside the enahncement you can write your logic first and after that the other logic would follow.

Regards,

Nagaraj

Former Member
0 Kudos
161

You need not create another implementation but just change the existing one.

Try: SE38 ->Enhance->Edit->Enhancement Operations->Show Implicit Enhancements->Change

@ Nagaraj - I didn't saw your post.

Please do what Nagaraj has suggested.

Edited by: rumhat on Jun 1, 2011 12:40 PM