Application Development Discussions
Join the discussions or start your own on all things application development, including tools and APIs, programming models, and keeping your skills sharp.
Showing results for 
Search instead for 
Did you mean: 

New subroutine added is not appearing in the object list after transport

Former Member
0 Kudos

Hi ,

I have added a new subroutine in the include program .This is fine in development server. When I transported this to quality,

the newly added subroutine is not reflected in the Object list and when I double click the subroutine in the PERFORM statement it is saying that the subroutine is not available. But the subroutine defination is available in the same include

and the program is recognising in debugging mode.

Can anybody please help me on this.




Former Member

Try reactivating the program from SE38 or SE80 in test system and then check once again.

I did that. I even tried re-transporting the changes to quality but still the same result.

Everything is activated.



Try these two options..

1., Go to SE80 for this program - right click on program- then other functions -> rebuild object list.

2. From menu for this progrm - Untilties - update navigation index.

After that you can see your nagivation works to your subroutine.

0 Kudos


As already told by Manohar, update the navigation index. It happens some times that navigation index is not proper.

0 Kudos

Thanks Manoher. It worked. You rock