Application Development Discussions
Join the discussions or start your own on all things application development, including tools and APIs, programming models, and keeping your skills sharp.
cancel
Showing results for 
Search instead for 
Did you mean: 

Modification in display of ALV report

Former Member
0 Kudos
180

Dear All.

I had to add three more columns in the report display ,and too between 3rd and 4th column in the display, and its using ...below mentioned FM.

CALL FUNCTION 'REUSE_ALV_FIELDCATALOG_MERGE'

EXPORTING

I_PROGRAM_NAME = g_repid

I_STRUCTURE_NAME = 'ZStructure'

CHANGING

CT_FIELDCAT = fieldcat_tab

EXCEPTIONS

OTHERS = 01.

IF SY-SUBRC <> 0.

MESSAGE ID SY-MSGID TYPE SY-MSGTY NUMBER SY-MSGNO

WITH SY-MSGV1 SY-MSGV2 SY-MSGV3 SY-MSGV4.

ENDIF.

*

sort itab1 by NAME.

CALL FUNCTION 'REUSE_ALV_GRID_DISPLAY'

EXPORTING

i_callback_program = g_repid

i_callback_html_end_of_list = 'ALV_END_OF_LIST'

i_structure_name = 'ZStructure'

i_grid_title = syst-title

it_fieldcat = fieldcat_tab

i_save = 'A'

TABLES

t_outtab = itab1

EXCEPTIONS

OTHERS = 01.

I HAD CHANGED THE ZSTRUCTURE BY ADDING THE DESIRED FIELDS BETWEEN THE THIRD AND FOURTH ROW...

but problem is ...there is no change in the output of the report...absolutely no change....same columns are coming and in same order...

how to solve this probelm??? Help me out...

I will reward the points.....

1 ACCEPTED SOLUTION

Former Member
0 Kudos
61

It should work if they are added in the structure. Just logout and try it again. Else manalluu loop thru the catalog and assign the order.

5 REPLIES 5

Former Member
0 Kudos
61

hi,

just check ur structure whether its active or not.

prajith

Former Member
0 Kudos
62

It should work if they are added in the structure. Just logout and try it again. Else manalluu loop thru the catalog and assign the order.

Former Member
0 Kudos
61

hi

give itab1 as ITAB1 --> make it full caps....see how your itab1 is filled..i.e. whether you are using into corresponding fields of or table itab...

if helpful, reward

Sathish. R

Former Member
0 Kudos
61

hi,

give the structure name in CAPITAL letter.

'ZSTRUCTURE'

in ur code.

Rgds

Reshma

Former Member
0 Kudos
61

Thanks every one.............. i had tried the suggestion given by u all...but when i logged out and logged in again..its works.....

for cross checking i had done again some changes..but even after activating structure its not worked but when i loggin again..its worked....

thanks for solutions.....

rewarded points...