Application Development Discussions
Join the discussions or start your own on all things application development, including tools and APIs, programming models, and keeping your skills sharp.
cancel
Showing results for 
Search instead for 
Did you mean: 

material no and group is not showing properly

Former Member
0 Kudos
226

Dear all,

in alv output, the material no and material group is not showing properly..

for e.g. matnr = 004125 & matkl = 076

it is showing only 4125 & 76

I hv check the data types and all.. but could not find the problem..

can u pls help me to solve it.

Thanks,

Dinesh

10 REPLIES 10

Former Member
0 Kudos
98

Hi

Use conversion exit for the material number CONVERSION_EXIT_MATN1_INPUT & for Matkl you can use CONVERSION_EXIT_ALPHA_INPUT .

Regards

Abhii

Edited by: Abhii on Sep 14, 2010 11:54 AM

0 Kudos
98

not solving the purpose.

0 Kudos
98

Hi,

Check your fieldcatelog you must have supressed the leading zeros then.

Regards,

Prashant

0 Kudos
98

hi ,

check for field property in fieldcat for that column

ls_fieldcat-no_zero = p_nozero .

you might have passed 'X' to ls_fieldcat-no_zero

in alv grid display fieldcat

Regards

Deepak.

Sandeep_Kumar
Product and Topic Expert
Product and Topic Expert
0 Kudos
98

the leading zeros are deleted by default.

in the fieldcatalog for both matnr and matkl mark LZERO = 'X'.

former_member555112
Active Contributor
0 Kudos
98

Hi,

What fields have you given as reference fields in the fieldcatalog?

Refer to MARA-MATNR and MARA-MATKL as the reference field and reference table.

Regards,

Ankur Parab

Former Member
0 Kudos
98

Hi friend,

I think problem is when you set ref_fieldname and ref_tabname in fieldcat. Try remove them.


"remove
*  ls_fieldcat-ref_tabname   = 'MATNR'.
*  ls_fieldcat-ref_fieldname = 'MARA'.

Please check,

Regards,

0 Kudos
98

Respected All,

Problem solved..

actually i was writing

fld_catalog-no_zero = 'X'.

but after becoming comment this line.. report is showing proper values.

Thank u all.

kesavadas_thekkillath
Active Contributor
0 Kudos
98

How are these two field declared in your internal table ?

Also try setting the output length in the field catalouge to 18 for matnr and 09 for MATKL

Former Member
0 Kudos
98

Query solved.

Thanks,

Dinesh