Application Development Discussions
Join the discussions or start your own on all things application development, including tools and APIs, programming models, and keeping your skills sharp.
cancel
Showing results for 
Search instead for 
Did you mean: 

Long running sap abap platform 1909 developer edition docker won't startup again

jcruz42
Explorer
0 Kudos

I have the HANA 1909 docker image on a Debian Server running with 24G RAM, 8 cpus and nearly 200G of available disk space.

I had the container running fine for quite sometime. I updated the license back in June and it expired this month.

I tried to update the license again but with no success, so I figured I'd remove the container and start over, since I have the image on the machine.

But to my surprise, when I create the container it takes FOREVER and then I'm prompted this:

The service HDB has failed to start and initialization is blocked until the problem is resolved
You can try your luck 10 times until initialization is terminated
Hint: docker containers can be joined by: docker exec -it <name> bash
Hint: Container must have at least 16GB RAM available
Hint: Container must have at least 70GB DISK free
Hit Return to continue


As I stated in the begining, it's cleary not a resorce problem as the machine is actually oversized.

A possible issue that I saw during my research is a problem with the kernel version https://answers.sap.com/questions/13602421/a4h-docker-image-no-longer-starts-up.html, but this is not my case since my environment has never been updated since it's creation and SAP container was running fine for months with the current kernel (5.10.0-8-amd64).

It's not a license problem because the error happens before any license step.

Regarding the license itself, I'm aware of the https://go.support.sap.com/minisap/#/minisap tool and the need to retrieve both "HDB - SAP HANA Platform Edition (64GB)"" and "A4H - SAP NetWeaver AS ABAP 7.4 and above (Linux / SAP HANA)" license files. And I know that they should be retrieved informing the correct HARDWARE KEYS.

I'm also aware of the need to adjust the SYSTEM-NR in the license files with "the corresponding number that was displayed during startup"; but I've saved this information before the container destruction so I have it anyways.

Robert Stefanov's incredible answer to this question https://answers.sap.com/questions/13727405/update-hdb-and-a4h-licenses-at-container-creation.html seems to be the definitive instruction guide to anyone who still have the image, and I've got most of information from there.

I'm trying the exact same docker run command after the container destruction:

docker run --stop-timeout 3600 -it --name a4h -h vhcala4hci --sysctl kernel.shmmni=32768 \<br>-p 3200:3200 -p 3300:3300 -p 8443:8443 -p 30213:30213 -p 30215:30215 -p 50000:50000 -p 50001:50001 -p 50013:50013 \<br>store/saplabs/abaptrial:1909 -agree-to-sap-license -skip-limits-check<br>


I also tried destroying the container and recreate it passing on the licenses:

docker run --stop-timeout 3600 -it --name a4h -h vhcala4hci --sysctl kernel.shmmni=32768 \<br>-p 3200:3200 -p 3300:3300 -p 8443:8443 -p 30213:30213 -p 30215:30215 -p 50000:50000 -p 50001:50001 -p 50013:50013 \<br>-v /root/HDB-2022-11-30-2nd-attempt.txt:/opt/sap/HDB_license \<br>-v /root/A4H_Multiple-2022-11-30.txt:/opt/sap/ASABAP_license \<br>store/saplabs/abaptrial:1909 -agree-to-sap-license -skip-limits-check<br>


But this becomes irrelevant as in either case, I do not even reach the license stage.

Any ideas? Usefull logs that will give me more accurate information than this wrong resource hint? I've looked up in the container but found nothing usefull.

I ran out of ideas here =/

Thanks!

4 REPLIES 4

jcruz42
Explorer

I did. I referenced the second link in my question.

As I said, the problem I'm facing occurs before the issues mentioned in the links you sent me:

My problem occurs after:

HDB: starting

<timestamp>
Start OK

and before:

hdb_license_update: starting
---

abo
Active Contributor
0 Kudos

(deleted my worthless answer, I missed a key element)

Former Member any ideas?

Former Member

Hi Jhonatan,

I had a similar (probably even the same) issue with "You can try your luck 10 times" at the very beginning of container start. It was the combination of Linux distro and container version. Don't remember exactly but it could be Oracle Linux 9 with the stock podman. The actual problem - I was not able to login in with " docker exec -it a4h bash" - it just returned an error. The same happens in the image itself. The start script tries "su - hdbadm" and it fails, hence the error.

The solution was to take another distro and install docker from https://docs.docker.com/desktop/install/linux-install/

But as you have the image, you can also try this https://github.com/rstenet/abap-1909-undocked. For me it works much better.

Happy hacking

Robert

jcruz42
Explorer
0 Kudos

Hi Robert,

Thanks, I'll look into it.