Application Development Discussions
Join the discussions or start your own on all things application development, including tools and APIs, programming models, and keeping your skills sharp.
cancel
Showing results for 
Search instead for 
Did you mean: 

logo

Former Member
0 Kudos
191

hi,

In ALV report i want to display the logo in top-of-page....please go through my coding once and tellme the mistake where it is.....

error showing me as...

Field "I_LOGO" is unknown. It is neither in one of the specified tables nor defined by a "DATA" statement.

<b> call function 'REUSE_ALV_COMMENTARY_WRITE'

exporting

it_list_commentary = t_header.

i_logo = 'trv_96_3068a'.</b>

and i upload the picture in OAER...

tell me how can i get the logo...in report..

raju

1 ACCEPTED SOLUTION

Former Member
0 Kudos
69

Hi

You should load your picture by trx smw0.

The logo can be display only in GRID and not LIST:

Try this:

CALL FUNCTION 'REUSE_ALV_COMMENTARY_WRITE'

EXPORTING

I_LOGO = 'ENJOYSAP_LOGO'

You can find this logo by SMW0: choose binary data

Max

Message was edited by: max bianchi

Message was edited by: max bianchi

7 REPLIES 7

RichHeilman
Developer Advocate
Developer Advocate
0 Kudos
69
call function 'REUSE_ALV_COMMENTARY_WRITE'
exporting
<b>it_list_commentary = t_header.</b>  <b><-- REMOVE THIS PERIOD</b>
i_logo = 'trv_96_3068a'.

Regards,

Rich Heilman

Message was edited by: Rich Heilman

Former Member
0 Kudos
70

Hi

You should load your picture by trx smw0.

The logo can be display only in GRID and not LIST:

Try this:

CALL FUNCTION 'REUSE_ALV_COMMENTARY_WRITE'

EXPORTING

I_LOGO = 'ENJOYSAP_LOGO'

You can find this logo by SMW0: choose binary data

Max

Message was edited by: max bianchi

Message was edited by: max bianchi

0 Kudos
69

Hei raju

Rick is right you have inserted a period in wrong place:

call function 'REUSE_ALV_COMMENTARY_WRITE'

exporting

it_list_commentary = t_header. <----


It's wrong

i_logo = 'trv_96_3068a'.

call function 'REUSE_ALV_COMMENTARY_WRITE'

exporting

it_list_commentary = t_header <----


It's right

i_logo = 'trv_96_3068a'.

Max

Message was edited by: max bianchi

0 Kudos
69

no display if i delete the . also...i think as u told me before in alv grid i have to do this...

it_list_commentary = t_header <----


It's right

i_logo = 'trv_96_3068a'.

i am trying..

thnk u for quick reply.

0 Kudos
69

Hi

The code is wrong so you should change it, but you're sure the logo is uploaded by right way.

So you should try to load the logo by SMW0, and after call it from your program.

Max

0 Kudos
69

Will you please tellme the process of load the logo by SMW0 ...i tried but failed to get....

once enter into the SMW0 then i have to select binary option then it is asking me for

pacakage

object name

object description

and next

thanks in advance..

raju.

0 Kudos
69

Hi

excuse me I'm confused: trx SMW0 is to load the pictura for SAP initial screen (at right side).

You are right: transaction OAER is right so:

1. Goto the transaction OAER

2. Enter the class name as 'PICTURES'

3. Enter the class type as 'OT'

4. Enter the object key as the name of the logo you wish to give

5. Execute

6. Then in the new screen select Standard doc. types in

bottom window

Click on the Screen icon

Now, it will ask for the file path where you have to upload the logo

7. Now you can use this logo in REUSE_ALV_COMMENTARY_WRITE

Max

P.S.: I try to load a picture (.GIF) and a picture (.BMP) and it works fine.

Message was edited by: max bianchi