Application Development Discussions
Join the discussions or start your own on all things application development, including tools and APIs, programming models, and keeping your skills sharp.
cancel
Showing results for 
Search instead for 
Did you mean: 

Issue With Function Module

Former Member
0 Kudos
87

Dear All ,

While calling one function module through my Program I am getting a error as "For typing of TABLES parameters, only table types should be used" in the Runtime in Production Client. But the same is been executed in the developement client no runtime error is coming.

Please advice on this.

Regards,

Nikhil

5 REPLIES 5

Former Member
0 Kudos
52

Please check the parameters passed to the function module.

The table type refered may be available in development and will not be transported to the production.

So check the datatype which is referred is transported to the production or not

former_member212005
Active Contributor
0 Kudos
52

Can you write, how you are calling the function module...

And is it a short dump?

And check the below link....it will be helpful

Typing of interface parameters

http://help.sap.com/abapdocu/en/ABENFUNCTION_PARAMETERS.htm

Former Member
0 Kudos
52

Hi.

Check the Tables tab of your FM in production, Any table is defined with "TYPE"?

Compare both development and production versions.

If any tabel is defined with TYPE change that to LIKE in Dev and retransport that.

Regards

0 Kudos
52

I Just Retransported it to production. Now its working fine.

Thanx for the clue.

Regards,

Nikhil

Former Member
0 Kudos
52

Hi,

Please check whther the table type used is also transported to production..