Application Development Discussions
Join the discussions or start your own on all things application development, including tools and APIs, programming models, and keeping your skills sharp.
cancel
Showing results for 
Search instead for 
Did you mean: 

IF_EX_ME_PROCESS_PO_CUST~POST / Modify PLIFZ

former_member183155
Active Contributor
0 Kudos
3,111

Hi all ,

Firstly, i know that ~PROCESS_ITEM method is prefered to modify item data. But, my requirement is non-match so that i have to check a custome field in header. That is why i have to modify item data (plifz) in ~POST method.

But, i tried to set-data but it is not working. Can you lead me to solve it ? However, i tried userexit when save button clicked but not working to modify standard field.

~POST METHOD

***************************************************************

CALL METHOD im_header->get_items
RECEIVING
re_items = lt_items_cl.

LOOP AT lt_items_cl INTO ls_item.


CLEAR ls_items.
CALL METHOD ls_item-item->get_data
RECEIVING
re_data = ls_items.

ls_items-plifz = '990'.
ls_item-item->set_data( ls_items ).

APPEND ls_items TO lt_items.
ENDLOOP.

****************************************************************

M.Ozgur Unal

1 ACCEPTED SOLUTION

former_member183155
Active Contributor
0 Kudos
511

Hi all ;

1927793 - ME_PROCESS_PO_CUST not triggered at custom field copy / change in ME21n / ME22n

That's why i cant solve my problem .

Regards.

M.Ozgur Unal

7 REPLIES 7

nomssi
Active Contributor
0 Kudos
511

Hi Mehmet,

POST( ) is also not the right place to change the data. It is intended for database operations, e.g. save to a custom table.

I suggest to move your logic to the CHECK( ) method.

JNN

former_member183155
Active Contributor
0 Kudos
511

Hi Jacques Nomssi,

I tried but check method might not give permission to set_data ...

Regards.

M.Ozgur Unal

former_member183155
Active Contributor
0 Kudos
511

Hello,

CHECK() is not working to set_data !!!

M.Ozgur Unal

former_member183155
Active Contributor
0 Kudos
511

Actually, i can not use PROCESS_ITEM() because of not working PROCESS_HEADER() method when a custom field is changed in header.

Is there any advice for solution ?

M.Ozgur Unal

nomssi
Active Contributor
0 Kudos
511

Hi Mehmet,

you might have problem with the firewall, check https://archive.sap.com/discussions/thread/207031

JNN

kiran_k8
Active Contributor
0 Kudos
511

Mehmet,

Check SAP Service Market place,if there is any information document on "firewall" which is being discussed here so that you will have more info before proceeding with the changes.

K.Kiran.

former_member183155
Active Contributor
0 Kudos
512

Hi all ;

1927793 - ME_PROCESS_PO_CUST not triggered at custom field copy / change in ME21n / ME22n

That's why i cant solve my problem .

Regards.

M.Ozgur Unal