Application Development Discussions
Join the discussions or start your own on all things application development, including tools and APIs, programming models, and keeping your skills sharp.
cancel
Showing results for 
Search instead for 
Did you mean: 

ICM_HTTP_SSL_ERROR in SM59 HTTP call

0 Kudos
1,306

I am getting message ICM_HTTP_SSL_ERROR when trying to do test connection in SM59 for connection type 'G' - HTTP call to external server

I have already installed SSL certificates which I got from URL.

Turned on SICF proxy recording and I see "500 SSL native error.

Here is the log from SMICM. Please let me know what could be the issue. I am able to connect to other URL but for this one.

->> SapSSLSessionInit(&sssl_hdl=000000000A19B390, role=1 (CLIENT), auth_type=3 (USE_CLIENT_CERT))

<<- SapSSLSessionInit()==SAP_O_K

      in: args = "role=1 (CLIENT), auth_type=3 (USE_CLIENT_CERT)"

     out: sssl_hdl = 000000000A504E20

->> SapSSLSetNiHdl(sssl_hdl=000000000A504E20, ni_hdl=12)

NiIBlockMode: set blockmode for hdl 12 TRUE

   SSL socket: local=192.168.122.10:3481  peer=198.34.224.193:443

<<- SapSSLSetNiHdl(sssl_hdl=000000000A504E20, ni_hdl=12)==SAP_O_K

->> SapSSLSetSessionCredential(sssl_hdl=000000000A504E20, &cred_name=0000000000BE7AE0)

   SapISSLComposeFilename(): Filename = "E:\usr\sap\SCP\DVEBMGS02\sec\SAPSSLCANP.pse"

<<- SapSSLSetSessionCredential(sssl_hdl=000000000A504E20)==SAP_O_K

      in: cred_name = "E:\usr\sap\SCP\DVEBMGS02\sec\SAPSSLCANP.pse"

->> SapSSLSetTargetHostname(sssl_hdl=000000000A504E20, &hostname=00000000003DE800)

<<- SapSSLSetTargetHostname(sssl_hdl=000000000A504E20)==SAP_O_K

      in: hostname = "stg30.ct.soa-gw.canadapost.ca"

->> SapSSLSessionStart(sssl_hdl=000000000A504E20)

   SapISSLUseSessionCache(): Creating NEW session (0 cached)

*** ERROR during SecudeSSL_SessionStart() from SSL_connect()==SSL_ERROR_CONNECTION_LOST

    session uses PSE file "E:\usr\sap\SCP\DVEBMGS02\sec\SAPSSLCANP.pse"

No Secude Error present in trace stack!

   SSL_get_state() returned 0x00002120 "SSLv3 read server hello A"

   No certificate request received from Server

<<- ERROR: SapSSLSessionStart(sssl_hdl=000000000A504E20)==SSSLERR_SSL_CONNECT

->> SapSSLErrorName(rc=-57)

<<- SapSSLErrorName()==SSSLERR_SSL_CONNECT

*** ERROR => IcmConnInitClientSSL: SapSSLSessionStart failed (-57): SSSLERR_SSL_CONNECT {00020022} [icxxconn.c 2005]

->> SapSSLSessionDone(&sssl_hdl=000000000A19B390)

<<- SapSSLSessionDone(sssl_hdl=000000000A504E20)==SAP_O_K

IcmConnConnect(id=2/34): free MPI request blocks

MPI<5683e>5a#7 GetInbuf -1 7388d0 217 (1) -> 6

MPI<5683d>51#4 GetOutbuf -1 6f87d0 65536 (0) -> 0000000005638840 0

2 REPLIES 2

nurullah_rstem2
Explorer
0 Kudos
144

Hi Raghu,

i am facing same problem. should you let me know the solution if you solved.

thanks in advance

0 Kudos
144

Did you install SSL certificate in transaction STRUST, i was getting this error after installing certificates so we developed webservice using C# and called C# webservice from ABAP