Application Development Discussions
Join the discussions or start your own on all things application development, including tools and APIs, programming models, and keeping your skills sharp.
cancel
Showing results for 
Search instead for 
Did you mean: 

HTML VIEWER cl_gui_html_viewer and MIME objects - can't display

Former Member
0 Kudos
384

Hi,

I try to display a dynamic HTML page with some pictures staright fro a ABAP list:

I have the following code snipet:

....

....

CALL METHOD html_control - >load_mime_object

EXPORTING

object_id = 'ZWN'

object_url = 'ZWN.GIF'

EXCEPTIONS

OTHERS = 1.

CALL METHOD html_control - >load_data

EXPORTING

type = 'text'

subtype = 'html'

IMPORTING

assigned_url = v_doc_url

CHANGING

data_table = lt_my_html

EXCEPTIONS

dp_invalid_parameter = 1

dp_error_general = 2.

IF sy-subrc EQ 0.

CALL METHOD html_control - >show_url

EXPORTING

url = v_doc_url

in_place = ' '.

endif.

All objects are checked in via SMW0.

In the HTML Code, I have the pictures this regular way:

....<im g sr c=zwn.gif......

If I have it run like this, the pictures are not displayed.

If I do it the way to leave out the HTML page and display it directly:

CALL Method ....load_mime_object.....

CALL Method....show_url, the picture is displayed.

What am I doing wrong?

3 REPLIES 3

holger_stumm2
Active Contributor
0 Kudos
96

Any thoughts?

0 Kudos
96

Hello Holger,

as the status of this thread is "Answered", I would be very thankful to get your solution.

Does it only work with the in-place-option or did you find something else.

THANK YOU !!!

0 Kudos
96

Hi Holger,

I can't see you fill lt_my_html.

Regards,

Clemens