Application Development Discussions
Join the discussions or start your own on all things application development, including tools and APIs, programming models, and keeping your skills sharp.
cancel
Showing results for 
Search instead for 
Did you mean: 

Function Module BAPI_ACC_DOCUMENT_POST does not exist

Former Member
0 Kudos

Hi All,

I am trying to create an accounting document in SAP using the BAPI "BAPI_ACC_DOCUMENT_POST". But when I try to execute the BAPI I am getting the error "Function module BAPI_ACC_DOCUMENT_POST does not exist".  I have checked using TCODE SE37 and also BAPI Explorer but could not locate the BAPI.

The SAP version that is being used in Release 4.6C.

Can anyone please suggest what could be the possible reason why this BAPI is not availble in the SAP version.

Best Reagrds

Sutirtha

1 ACCEPTED SOLUTION

raymond_giuseppi
Active Contributor
0 Kudos

What is your exact version, SP. As, If I remember correctly, those BAPIs were originally part of PI 2001.1 ?

Regards,

Raymond

PS: On any transaction/menu -> Navigate to menu system, status, version icon, look for PI.

6 REPLIES 6

laurent_fournier2
Contributor
0 Kudos

Hi,

I checked in a 4.6c system and the bapi exists. Does function group ACC9 exist in your system ?

0 Kudos

Hi,

When I checked for this accounting group ACC9 I could not find it.

How do I get that installed?

Thanks in advance.

Best Regards

SR

Former Member
0 Kudos

Hi,

try FM "POST_DOCUMENT"

thx

raymond_giuseppi
Active Contributor
0 Kudos

What is your exact version, SP. As, If I remember correctly, those BAPIs were originally part of PI 2001.1 ?

Regards,

Raymond

PS: On any transaction/menu -> Navigate to menu system, status, version icon, look for PI.

0 Kudos

Hi Raymond,

I have the checked for PI in Menu->System->Status->Version icon and under Component Tab I could see :

  1. ST-PI - 2008_1_46C (Release)
  2. ST-A/PI - 01M_R3_46C (Release)

Under SupPack Tab I could see :

  1. SAPKITLRA1 - ST-PI 2008_1_46C: SP 0001
  2. SAPKITLRA2 - ST-PI 2008_1_46C: SP 0002
  3. SAPKITLRA3 - ST-PI 2008_1_46C: SP 0003

That's all the PI I could find. Is there any specific verison(s) I should be looking for?

Thank & Regards

Sutirtha

0 Kudos

Sorry but PI is neither ST-PI nor ST-API - look for a name like "R/3 Plug-In, 2004.1" (or more recent, i don't remember last version for 46c)

Look at OSS for a note like Note 704564 - R/3 Plug-In: PI 2004.1 installation/delta upgrade to install the PI and get access to the ACC "new" BAPI (at time of note publication )  (*)

Start with Note 214503 - Release strategy for PI and PI-A add-ons

Regards,

Raymond

(*) and other BAPIs of course.