Application Development Discussions
Join the discussions or start your own on all things application development, including tools and APIs, programming models, and keeping your skills sharp.
cancel
Showing results for 
Search instead for 
Did you mean: 

FM IDOC_INPUT_HRMD not working properly

Former Member
0 Kudos

Dear All,

I am using FM IDOC_INPUT_HRMD to update infotype data but this FM is deleting the values already present.

For example:

When I use FM IDOC_INPUT_HRMD to update data in infotype 0000, it deletes all the entries already present in 0000 against that pernr and creates a single entry in it(which lacks few basic fields like AEDTM and UNAME). Also, it deletes data for that particular pernr from all the other infotypes.

Any suggestion/help would be highly appreciated.

Thanks in advance!

5 REPLIES 5

iftah_peretz
Active Contributor
0 Kudos

Hey,

Sorry to be the "bad guy" here, but, you are using a "Not released" FM (you can see it in the 'Attributes' tab of the FM), thus, you should not expect a certain behavior.

You should use "Released" FM/BAPI/Classes or develop your own logic (based on your needs).

0 Kudos

Hi Iftah,

Thanks for the information.

When dealing with HRMD_ Idocs, be aware of the difference between Insert and Update!

If you use the operator "I" Insert, this will delete everything that might already be existing for a certain personnel number and infotype, and after that only insert the data provided in the Idoc. "U" Update will keep the existing data and add/change the update.

Sounds like this might be the case for you here...

0 Kudos

Hi Jörgen,

Thanks for your response. I checked and found it was an issue of 'I' in place of 'U'. I can now modify infotypes successfully. Thanks again.

I have another issue now, when I insert a record now with I', it creates record in 0000, 0001 and 0002. But for rest of the infotypes like 0006, 0009 etc, I receive an error: "Object 01 ,P ,<pernr> does not exist: infotype 0006 cannot be created" Could you please suggest some way out for this?

Regards,

Rishali

former_member200754
Participant
0 Kudos

Hello Rishali Raj,

May i know what is your solution for this issue.

i faced the same issue, i try to regenarate idoc via we19 and every entry in segment existed in 0002 was deleted and only the new one in idoc is inserted, i already update the field E1PLOGI-OPERA = 'U'

but still not work,

thank you