Application Development Discussions
Join the discussions or start your own on all things application development, including tools and APIs, programming models, and keeping your skills sharp.
cancel
Showing results for 
Search instead for 
Did you mean: 

First record is not an IDOC control record - Error

Former Member
0 Kudos
904

When I am trying to import orders in my test system through RSEINB00 , it is giving me this error "First record is not an IDOC control record"

But if I manually do it through test tool , it post successfully.

I tried different files which have been posted into production client successfully but still the same error.

It was working just fine until yesterday. Today I modified one file and ran it and it gave me the error. Now its giving me the error in all the file i try.

Any clues ??

1 ACCEPTED SOLUTION

ferry_lianto
Active Contributor
0 Kudos
92

Hi,

Please check the partner profile (WE20) and IDoc ports (WE21) setup, perhaps someone changed them by mistake.

Also please check the IDoc file content whether there is IDoc control record (EDIDC) information or not.

Regards,

Ferry Lianto

2 REPLIES 2

ferry_lianto
Active Contributor
0 Kudos
93

Hi,

Please check the partner profile (WE20) and IDoc ports (WE21) setup, perhaps someone changed them by mistake.

Also please check the IDoc file content whether there is IDoc control record (EDIDC) information or not.

Regards,

Ferry Lianto

0 Kudos
92

I already checked WE20 and WE21. They look fine . I debugged it and found that the current record no. in the start of the file processing should be 000000. But it is 000020. This is an entry in EDFI2 table. I deleted that entry using the FM EDI_EDFI2_DELETE. This is now working.