Application Development Discussions
Join the discussions or start your own on all things application development, including tools and APIs, programming models, and keeping your skills sharp.
cancel
Showing results for 
Search instead for 
Did you mean: 

EXPORT IMPORT not working in implicit enhancements

Former Member
0 Kudos
558

Hi,

I need to export from an implicit enhancement spot a deep structure data to another implicit enhancement spot.

export is_replord_conf = is_replord_conf to memory id 'REPLE' .
import is_replord_conf = is_replord_conf from memory id 'REPLE' .

For some reason i am not getting values in second implicit enhancement point.

I will be thankful if you can guide.

Thanks.

1 ACCEPTED SOLUTION

SuhaSaha
Advisor
Advisor
0 Kudos
98

Hello,

After the EXPORT & IMPORT statements what is the value of SY-SUBRC? In the debug mode did you check if the memory id 'REPLE' is available after the EXPORT & before the IMPORT?

BR,

Suhas

4 REPLIES 4

SuhaSaha
Advisor
Advisor
0 Kudos
99

Hello,

After the EXPORT & IMPORT statements what is the value of SY-SUBRC? In the debug mode did you check if the memory id 'REPLE' is available after the EXPORT & before the IMPORT?

BR,

Suhas

0 Kudos
98

After the EXPORT & IMPORT statements what is the value of SY-SUBRC?

Just a little remark, test of SY-SUBRC is only for IMPORT, while any failure in EXPORT would raise an exception, catchable or not.

0 Kudos
98

My bad ... Thanks for pointing that out!

Sandra_Rossi
Active Contributor
0 Kudos
98

Hi sanj_dell,

why did you give me credit, I didn't give any solution! You can change it. Only Suhas gave you a clue to find the solution by yourself.

By the way, was your issue related to implicit enhancements? (I know it's not, but I'd like to hear it from you)

Thanks

Sandra