Application Development Discussions
Join the discussions or start your own on all things application development, including tools and APIs, programming models, and keeping your skills sharp.
cancel
Showing results for 
Search instead for 
Did you mean: 

Error "FAIL: process disp+work Dispatcher not running" when running docker image

vitoria-alecrim
Explorer
2,324

Hello dear colleagues,

I am installing the ABAP Platform 1909, Developer edition docker image.

After run the docker command, I am struggling with the error shown below:

StartWait
FAIL: process disp+work Dispatcher not running
Worker Processes: the start command failed, exit code=2
The service Worker Processes has failed to start and initialization is blocked until the problem is resolved
You can try your luck 10 times until initialization is terminated
Hint: docker containers can be joined by: docker exec -it <name> bash
Hint: HDB license must not be expired
Hint: HDB must be running
Hint: AS ABAP license must be valid
Hit Return to

P.S.: The OS system is Windows 10 Pro.

KR,

Pietro

7 REPLIES 7

0 Kudos
939

Same issue on Fedora 33 VM

profitlich42
Participant
0 Kudos
939

same issue in a debian 10 VM

abo
Active Contributor
0 Kudos
939

The usual suspects are:

  1. not enough memory: the host should be able to spare 16GB for the container alone
  2. expired license

I'm running it just fine on a 32GB Debian/testing desktop. There's room for running Eclipse on the same machine, so it's not particularly tight.

By the by, for people having the same issue: it's better to use this menu item

profitlich42
Participant
0 Kudos
939

I run a stripped down debian VM with 24GB RAM - should be fine this way

somnath
Active Participant
0 Kudos
710

I am experiencing this issue very recent as it used to work quite will since last 8  months.I am using windows 11 with 32GB RAM. Recently I reinstalled the latest version 1909_SP01 and I have all the licenses valid.

Any suggestions?

- Thanks.

0 Kudos
670

Hey, we are encountering the exact same issue. I opened a blogpost regarding this, but unfortunately with no replies yet. Do you have any idea whether it's possible to extract the data of the old container (e.g. existing ABAP Coding on the system) and move it to a newly created system?

0 Kudos
652

Hi, no I don't have that knowledge how to extract old container content generally i push code to git for safer side. Anyways, i was doing some R&D with certificate and altered some configuration in RZ10 and that caused certain issues seems. I created a new container and it works without any issue till now. I don't have a better answer as of now. Awaiting other's advice.