Application Development Discussions
Join the discussions or start your own on all things application development, including tools and APIs, programming models, and keeping your skills sharp.
cancel
Showing results for 
Search instead for 
Did you mean: 

EN is not activated for smartform and has no errors

Former Member
0 Kudos
162

Hi Everyone,

I was looking at couple of threads on topic "smartform name" EN is not activated and has no errors, but I couldn't get a proper answer. So posting my query here.

I had a created a smartform for dunning process for languages F (French) and N (Dutch). While creating, in language attributes, under translation I had chosen the radio button Into selected languages and specified the languages and at the window level also I had maintained the condition on the language key (eg: wa_tab-spras) and activated without any errors.

After the configuration when we are checking it for a FR customer or NL customer, we are getting error saying "For smartform EN is not activated and has no errors".

Please suggest me how can I fix this error. Hoping for a solution...

Thanks & Regards,

Kumudwini.

5 REPLIES 5

former_member201275
Active Contributor
0 Kudos
50

Hi Kumudwini,

I think note 852250 will help your issue. Please let me know.

former_member187748
Active Contributor
0 Kudos
50

Hi,

please check that it is generating any function module or not, once please change the General attribute as Into all Languages, and see is it working or not

0 Kudos
50

Hi Sanjeev,

Yes, it is generating the function module and I changed the general attributes into all languages.Will check and get back to you..

Regards,

Kumudwini.

former_member201275
Active Contributor
0 Kudos
50

Another suggestion I have: Select the menu option Form -> Check -> Definition and complete the actions specified in the resulting message.

0 Kudos
50

Hi Glen,

Check was successful.

Regards,

Kumudwini.