Application Development Discussions
Join the discussions or start your own on all things application development, including tools and APIs, programming models, and keeping your skills sharp.
cancel
Showing results for 
Search instead for 
Did you mean: 

Eclipse ADT Unit Testing Error

jdloranger
Participant
633

Current System...

SAP NW 7.52

Eclipse Oxygen 4.7.3a

ADT version 2.102.1

The Issue...

I have been working towards employing Test Driven Development and Unit Testing in my new development.

However, just within the past week I have encountered an issue with writing new unit tests in new global classes.

Generally, I will create the framework of the unit test with the one failing test, which should execute and show a failed test. However, now I am getting an Eclipse internal error message and the tests do not execute. See attached images.

Oddly, when I go into another pre-existing class, where i have fully developed unit tests, they will run without issue, no Eclipse internal error.

What I don't know is if this is an error with Eclipse or with ADT?

Here is the displayed error.

Here is the unit test class.

I have also submitted a bug ticket to Eclipse.

5 REPLIES 5

Meinrad
Participant
173

I have a very similar issue in my development environment. It seems as old unit tests are working - but not newly created. (Not really sure about this. Just a feeling)

The very same Unit Tests works well in SE80.

Version: Oxygen.3a Release (4.7.3a)

Is there any place / log I should check additionally. The error message from Eclipse is not really helpful.

173

Meinrad,

I agree the error message is useless and I have searched high and low on the net for anything similar, with no luck. So I did the following:

  1. Re-installed the same version, 4.7.3a (April 2018), got the same issue.
  2. Installed one version prior, 4.7.3 (March 2018), no issue.
  3. Installed Eclipse Photon, no issue. I'm sticking with Photon for now. The additional development tools not yet available will catch by the time I am ready to try/use them

Additionally, there hasn't been any action taken on my reported bug, at Eclipse.org.

Kind regards,

Justin

former_member201346
Active Participant
173

Hi Justin,

we have used an API that is only available as of Eclipse Photon. I don't know have fast we can fix this. Switching from Eclipse Oxygen to Photon or 2018-09 will solve the problem.

Regards, Felix

jdloranger
Participant
0 Kudos
173

Thank you Felix.

I installed Photon and am using that version now.

Justin

Meinrad
Participant
0 Kudos
173

Hi Felix,

upgrade to Photon worked for me as well.

Thanks + regards

Meinrad