Application Development Discussions
Join the discussions or start your own on all things application development, including tools and APIs, programming models, and keeping your skills sharp.
cancel
Showing results for 
Search instead for 
Did you mean: 

Download ABAP in Eclipse

0 Kudos
511

Hello,

does anybody now where I can download the eclipse with integrated ABAP tools? Unfortunately I can't find anything.

Thank!

Viktor

1 ACCEPTED SOLUTION

gregorw
Active Contributor
0 Kudos
99

Dear Viktor,

AiE is now officially released. Check out Note 1718399 - RTC of ABAP Development Tools for SAP NetWeaver.

Best regards

Gregor

9 REPLIES 9

UweFetzer_se38
Active Contributor
0 Kudos
99

Hi Victor,

the ABAP Development Tools for SAP NetWeaver aka ABAP in Eclipse is still in beta, no GA date announced yet.

But as you are an SAP employee you may kindly ask a dev colleague near you

Best regards

gregorw
Active Contributor
0 Kudos
100

Dear Viktor,

AiE is now officially released. Check out Note 1718399 - RTC of ABAP Development Tools for SAP NetWeaver.

Best regards

Gregor

0 Kudos
99

Rohit,

I was trying to install AiE in my laptop following the instructions mentioned in "adt_731_installation_guide.pdf" but unfortunatelly when trying to install the ABAP plugin for Eclipse the following error appears (in the plugin installation wizard)

Cannot complete the install because one or more required items could not be found.

  Software being installed: ABAP Development Tools 1.0.3 (com.sap.adt.core.feature.group 1.0.3)

  Missing requirement: ABAP Development Tools Communication Framework 1.0.2 (com.sap.adt.fwk.ci.feature.group 1.0.2) requires 'org.eclipse.emf.workspace.feature.group [1.4.0,2.0.0)' but it could not be found

  Cannot satisfy dependency:

    From: ABAP Development Tools 1.0.3 (com.sap.adt.core.feature.group 1.0.3)

    To: com.sap.adt.fwk.ci.feature.group [1.0.2]

my Eclipse SDK version is 3.7.2

Any suggestion?

gregorw
Active Contributor
0 Kudos
99

Dear Jorge,

I also had this problem. I've installed a wrong component of the required Eclipse features described on page 20/21 of the guide. According to the error message it is the Feature:

EMF Model Transaction Workbench Integration

Best regards

Gregor

0 Kudos
99

In case you don't care about the size of the underlying Eclipse package and you don't get confused by tools you dont' need, the "Eclipse Modeling Tools" package provides most of the installation requirements. The only things missing are the Mylyn related components.

Best Regards

Felix

0 Kudos
99

Yes you are right,I didn't noticed about the comment on that page

0 Kudos
99

Hi Gregor, thanks for your reply! I will try it as soon as possible. 😉

gregorw
Active Contributor
0 Kudos
99

Dear Jorge,

to make this step easier I've created the Wiki Page: AiE easy installation where you can download a so called P2F file that will allow you to install all required components without manually searching them.

Best regards

Gregor