Application Development Discussions
Join the discussions or start your own on all things application development, including tools and APIs, programming models, and keeping your skills sharp.
cancel
Showing results for 
Search instead for 
Did you mean: 

Deactivating ASE Audit - NPL - 752SP04 on Linux: Oracle Virtual Box[DeveloperEdition]

eric_martorana
Explorer
0 Kudos

Hello,

I successfully installed the NPL system, but I cannot deactivate ASE Audit

I followed the instructions below (from the concise guide):

su -l sybnpl

isql -Usapsa -X -SNPL

sp_configure 'auditing', 0

go

And then I get:

Msg 10331, Level 14, State 2:

Server 'NPL', Procedure 'sp_configure', Line 1310:

Permission denied, database master, owner dbo. You need the following

permission(s) to run this command: MANAGE SECURITY CONFIGURATION.

(return status = 1)

Questions :

1) how can i authorize sapsa the correct permission ?

2) should i use another user instead of sapsa ?


Thanks in advance,

Kr

Eric.

2 REPLIES 2

eric_martorana
Explorer

I solved it thanks to a blog (special thanks to maruskin)

The command below has to be launched with sapsso , not with sapsa

But when I launched the command with sapsso I received another error :

The current 'max memory' value '736443', is not sufficient to change the

parameter 'auditing' to '0'. 'max memory' should be greater than 'total logical

memory' '736621' required for the configuration.

So deactivating ASE audit has to be done in 2 steps:

1) with sapsa, extend memory:

isql -Usapsa -X -SNPL

sp_configure 'max memory',740621

go

quit

2) and then with sapsso:

isql -Usapsso -X -SNPL

sp_configure 'auditing', 0

go

quit


It worked fine for me (without reboot between the 2 steps).

Thanks

0 Kudos

Thanks, Eric. Can you please add a link to this blog post of Maruskin, since I am not familiar with it?
I will update the docu accordingly. Would be nice to link to the blog post - both for assistance, and attribution.

Thanks and best wishes,

Julie.