Application Development Discussions
Join the discussions or start your own on all things application development, including tools and APIs, programming models, and keeping your skills sharp.
cancel
Showing results for 
Search instead for 
Did you mean: 

Cyrillic characters are not getting copied properly

atulmittal07
Explorer
0 Kudos
1,647

Hi SAP Gurus,

I am getting one issue while copying Cyrillic(Russian) characters from PDF which is originally generated from SAP system using FM "CONVERT_OTFSPOOLJOB_2_PDF". The characters are not getting properly copied and after pasting it in Google or Text or Word file, it is giving me some gibberish characters e.g. ¾ßØáÐÝØÕ ÃàÞÒÕÝì.

Please help me out here in resolving this problem.

15 REPLIES 15

former_member259807
Active Participant
0 Kudos
446

Are these characters only visible in Google, Text or Word? Is the PDF file itself ok?

atulmittal07
Explorer
0 Kudos
446

Yes, in PDF these characters are fine, even in print preview of spool also they are fine, this problem is coming only when I copy and paste it somewhere(Google/Text/Word) else.

ArthurParisius
Contributor
0 Kudos
446

Have you tried changing the letter type to a Cyrillic lettertype before pasting the characters?

atulmittal07
Explorer
0 Kudos
446

@arthur, these characters are of type TimesNewRoman font family and they are printing fine in the pdf file, let me know any other font which supports Cyrillic characters or please enlighten me with "Cyrillic lettertype" and how can I convert it?

hedvig_rohonyi
Employee
Employee
0 Kudos
446

Hello Atul,

Please check the following note resolves this issue: 2011637 - Copy & Paste from PDF file .

Please implement the code corrections of note 2011637 if it is relevant for your system and set the parameter ADD_TOUNICODE to 'ON' via report RSTXPDF3. Then please test again.

Best regards,

Hedvig

0 Kudos
446

Thanks Hedvig, But I am not able to see ADD_TOUNICODE parameter in RSTXPDF3 report.

hedvig_rohonyi
Employee
Employee
0 Kudos
446

Hi Atul,

please implement the the code corrections of note 2011637 and than set the parameter ADD_TOUNICODE to on.


This correction affects only the cascading font PDF conversion (see SAP Note 1704919 -> please set the parameter USE_CASCADING also)

Best regards,
Hedvig

0 Kudos
446

Hi Hedvig, thanks for the suggested thing. But, I am not able to open the notes link, moreover, when I turned on USE_CASCADING parameter in RSTXPDF3 report, after that neither I'm able to see most of the Cyrillic characters in PDF nor the characters which are getting displayed are getting copied(same issue).

0 Kudos
446

Hello Atul,


The best solution here would be to use the Unicode PDF (UPE) conversion as per SAP notes 1822639, 999712.
The requirement to use the UPE solution is described in SAP note

1738670 - Adjustments to the PDF converter for UPE

If the option UPE_FONTS_CASC is available on your system, you don't need to upload own fonts, the fonts of the SAP font repository is used for this.

Other case if you set the option USE_CASCADING the report RSTXPDF2UC (instead of RSTXPDF2) must be used to load fonts to the SAP system that contain the cyrillic characters. SAP Note 999712 contains more detailed information.
See please my attachment.


Best regards,
Hedvig

cadata-bcp-chat-sae-answersanswers-scnupe.png

0 Kudos
446

Hi Hedvig, I implemented whatever SAP Notes you mentioned and turned on all three parameters in RSTXPDF3 report, issue still persists.

0 Kudos
446

Hi Atul,

which device type do you use for creating OTF? Did you use SWINCF/ PDFUC? As note

2011637 describes, the correction affects only the cascading font PDF conversion (Note 1704919).

Best regards,

Hedvig

0 Kudos
446

We are using SAPWIN device type to print Cyrillic in OTF format. Do we need it to change to something else?

0 Kudos
446

Hi,

please use the unicode device type SWINCF. If the option UPE_FONTS_CASC is activated on your system, you don't need to upload own fonts via report RSTXPDF2UC.

Best regards,

Hedvig

ArthurParisius
Contributor
0 Kudos
446
In Notepad if you via Format, lettertype You should see an option for script, you should have the option for Cyrillic, see the screenshot.

It's in Dutch but you should have simular options.

atulmittal07
Explorer
0 Kudos
446

@arthur, tried, didn't work 😞