Application Development Discussions
Join the discussions or start your own on all things application development, including tools and APIs, programming models, and keeping your skills sharp.
cancel
Showing results for 
Search instead for 
Did you mean: 

Custom Segment field is getting cleared in ZCOSMAS01

Former Member
0 Kudos

Hi All

We have created Idoc extension ZCOSMAS01 for Basic type COSMAS01, with custom segmetn having one Z field.

This is inbound scenarion. The Sending system has confirmed that they are sending this field, but in receiving system this field is blank.

Searched forum but did not found answer.

Any Ideas ?

3 REPLIES 3

Jelena
Active Contributor
0 Kudos

It's not enough just to extend the IDoc. You need to do something to populate the segment. Depending on how the IDocs get created, this would need to be done in the middleware or in the code (e.g. function) that creates the IDoc.

Former Member
0 Kudos

Hi jelena,

Thanks for reply. My scenario is inbound scenario and this field exists in sending system. They have confirmed that through PI its been sent to receiving system correctly.

But in receiving system Idoc its getting cleared. Debugged the function module IDOC_INPUT_COSTCENTER, but could not find any place where its getting cleared.

Is there anything which I am missing?

Former Member
0 Kudos

Hello,

Are you using Standard input IDoc FM for inbound CUSTOMIZED Basic type ?

Is it taking care of your custom Segment population?

Edited by: anuradha singh on May 9, 2011 12:52 PM