Application Development Discussions
Join the discussions or start your own on all things application development, including tools and APIs, programming models, and keeping your skills sharp.
cancel
Showing results for 
Search instead for 
Did you mean: 

CUA installation

0 Kudos

Dear All,

We would implement the CUA for all of our other environments such BW - APO - CRM - LSO, R/2, and Solution Manager...

We are concern about these heterogeneous landscape, I mean these systems are not in the same SP or in hte same patch level.

Would we have to contend with upgrades to the CUA which would require a testing environment ?

Netweaver is the direction for doing all the security work in SAP, using RFC connections to the various SAP environments.

Do you have any positive information on doing this ?

Can we have the CUA on one Server and connect to all other applications

at different release levels and service pack levels ?

All inputs will be very welcome,

Thanks in advance,

1 ACCEPTED SOLUTION

Former Member
0 Kudos

Hmmm...

When ever I see you ask a question, I find it interesting and try to answer to help.

But this one is more strange than the others...

> We would implement the CUA for all of our other environments such BW - APO - CRM - LSO, R/2, and Solution Manager...

R/2?

> We are concern about these heterogeneous landscape, I mean these systems are not in the same SP or in hte same patch level.

If R/2 is correct, then see the ABAP keyword documentation in tcode ABAPDOCU on statament "EXIT" (and also "STOP").

> Would we have to contend with upgrades to the CUA which would require a testing environment ?

Yes.

> Netweaver is the direction for doing all the security work in SAP, using RFC connections to the various SAP environments.

Not really. There are newer technologies such as services and proxies, which also need to be secured. But they will not be available for R/2 systems. And also not in the same way for R/3 systems. But possibly for ECC systems, depending on your release and SP level.

> Do you have any positive information on doing this ?

Upgrading? Yes.

I know from a friend of mine in Peru, that many SAP systems are still on older releases. On higher releases there are many more functional advantages, the security is improved natively in many areas, but in others it is more tricky (mostly because it is new, but than is nothing new).

Luckily, the higher release levels (7.00, 7.10 and 7.20) have a planned longer lifecycle than the previous WAS released > 6.10 and support as far as I know. And corrections are downward compatible, but not to R/2...

> Can we have the CUA on one Server and connect to all other applications

> at different release levels and service pack levels ?

Generally yes, and it is recommended that the CUA master is on the highest release. The SAP kernel is generally downward compatible (although the child on an R/2 application might be stretching your luck...) and the application components only to a limited extent, and in so far as compatability is possible.

> All inputs will be very welcome,

Hope that helps. I think it will be easier for you to upgrade your ERP (Finance, MM, SD, etc) system, than downgrade the CUA in whatever way. That would be more sustainable.

Based on this thread and your other posts, you are living in very interesting times...

Cheers,

Julius

1 REPLY 1

Former Member
0 Kudos

Hmmm...

When ever I see you ask a question, I find it interesting and try to answer to help.

But this one is more strange than the others...

> We would implement the CUA for all of our other environments such BW - APO - CRM - LSO, R/2, and Solution Manager...

R/2?

> We are concern about these heterogeneous landscape, I mean these systems are not in the same SP or in hte same patch level.

If R/2 is correct, then see the ABAP keyword documentation in tcode ABAPDOCU on statament "EXIT" (and also "STOP").

> Would we have to contend with upgrades to the CUA which would require a testing environment ?

Yes.

> Netweaver is the direction for doing all the security work in SAP, using RFC connections to the various SAP environments.

Not really. There are newer technologies such as services and proxies, which also need to be secured. But they will not be available for R/2 systems. And also not in the same way for R/3 systems. But possibly for ECC systems, depending on your release and SP level.

> Do you have any positive information on doing this ?

Upgrading? Yes.

I know from a friend of mine in Peru, that many SAP systems are still on older releases. On higher releases there are many more functional advantages, the security is improved natively in many areas, but in others it is more tricky (mostly because it is new, but than is nothing new).

Luckily, the higher release levels (7.00, 7.10 and 7.20) have a planned longer lifecycle than the previous WAS released > 6.10 and support as far as I know. And corrections are downward compatible, but not to R/2...

> Can we have the CUA on one Server and connect to all other applications

> at different release levels and service pack levels ?

Generally yes, and it is recommended that the CUA master is on the highest release. The SAP kernel is generally downward compatible (although the child on an R/2 application might be stretching your luck...) and the application components only to a limited extent, and in so far as compatability is possible.

> All inputs will be very welcome,

Hope that helps. I think it will be easier for you to upgrade your ERP (Finance, MM, SD, etc) system, than downgrade the CUA in whatever way. That would be more sustainable.

Based on this thread and your other posts, you are living in very interesting times...

Cheers,

Julius