Application Development Discussions
Join the discussions or start your own on all things application development, including tools and APIs, programming models, and keeping your skills sharp.
cancel
Showing results for 
Search instead for 
Did you mean: 

Create new Abap project with Eclipse -> internal error javax/activation/MimeTypeParseException

opossumpadla
Discoverer
1,117

Hi,

i am trying to create new ABAP Project, but getting always this error:

An internal error occurred during: "Logging on to system 'MiniSAP'".
javax/activation/MimeTypeParseException

I am using SAP training system, all works fine, connection to server is ok. All required ABAP components for Eclipse Photon are installed.

Any idea, that could causes this error?

Thank's in advance!

Max

10 REPLIES 10

Former Member
0 Kudos
157

I'm getting this error as well. Any news on your end?

opossumpadla
Discoverer
0 Kudos
157

Unfortunately not

0 Kudos
157

could you try to delete .metadata folder and create project again? maybe in eclipse log have the information why it got exception. maybe you have to install again.

0 Kudos
157

me to, I'm getting this error as well. delete .metadata folder problem still show:

An internal error occurred during: "Logging on to system 'AZSAP'".

javax/activation/MimeTypeParseException

I use of system OS ADT

former_member282335
Discoverer
0 Kudos
157

This is probably because you are using JDK 11.. just use JDK 1.8,, worked for me....

former_member428933
Discoverer
0 Kudos
157

Hello, I am facing the same issue. did any of you guys had this resolved?

0 Kudos
157

Hi apaarmalhotra !

First, which version of Eclipse / Java you’re using?

Check this and if you installed a proper version of ADT.

Br,

Pacheco.

former_member428933
Discoverer
0 Kudos
157

Hi Raphael,

I am using eclipse photon with JDK 11.0 on my macbook. I saw above msg from Felipe saying just use JDK 1.8 instead.

Do you think its a right option and if yes how can i go back to JDK 1.8?

Thanks

Apaar

0 Kudos
157

Actually i tried with JDK 1.8 as well now. i changed it from 11 to 1.8 , restart eclipse , still same issue.

asotoco
Discoverer
0 Kudos
157

Hi team...

You have to open the folder

C:\Users\[user]\eclipse\jee-2020-09\eclipse

Edit the file eclipse.ini and adjust the following parameters

-vm [C:\jdk1.8.0_110\jre\bin]

-Dosgi.requiredJavaVersion=1.8

I hopew this is helpful for you

Regards.